Texture map resolution is changing?

For some reason the texture map resolution within my Editor is changing.
When the material editor is open, and I click the node of the texture map, I get full resolution.

After closing the material editor, the texture map inside the viewport is losing the resolution and looks kinda blurry.

What settings do control this?

Texture Streaming

Project Settings>>Rendering>>Textures>>Texture Streaming

This can happen when the “texture pool” of unreal is full. You can increase the pool size by putting the following code into the “MyProject/Config/DefaultEngine.ini” file:

r.Streaming.PoolSize = “4096”

Put just the 2nd line of the code in there if you already have a section for the RendererSettings.

Why is your pool full? It might be too small. You might have a lot of high resolution textures or you might have very high light map resolution settings. It can also happen when you have a lot of textures that are not a power of 2 (…, 512, 1024, 2048). Those textures will always be full size while the ones that are a power of 2 will be reduced in size when it is not necessary to have them full size (because you see them from the distance only).

Someone please help me. When press play it is looking fully blurred but it is working and it shows me at left corner as “Texture streaming pool over 95Mib budget”