Download

Texture looks bad at close range?

Hey Guys,

So I am using high res texture around 1024 x 1024 and maybe 2048 / 2048 for like a (wall) using substance painter by the way. When I export it to Unreal Engine 4 and look at on a level the quality is bad when up close you can see the detail (blurred) and also tried another texture like grass for a floor and it does not look great compared to how it looked it in substance / photoshop.

Any pointers or tips?

Usually things do look more blurry when you get close to them, without a screenshot there’s no way to tell if there’s a difference between the texture and what it looks like in-game.
What can help to have high detail is to use tiled textures so you can have a low resolution texture create high detail.

Will tiling actually increase resolution?

If you have a tiled texture you can make it really small so that it has a high pixel density per unit and then tiling will cover the whole area. That’s how you would do things like brick where you want to have lots of bricks without having to have a really big texture to fit them all, just have a small image with a few bricks and it can tile for the rest.

Without knowing what the texture is, and for what kind of object, there is different ways to do it.
There is the option to have micro details, where you have an extra tiling texture with extra details: Adding Detail Textures | Unreal Engine Documentation
And you can using masking as well, for example, where you mask out the bricks and the grout, and then have a detailed brick texture material, and a grout material. Unless your texture is unique, that is a good way to get details textures, as you can break up the repeating tiling in the material.

I agree with darth, that using large textures should be saved for things that really need them, and trying to make a lot out of smaller textures (and then layering over other things to give more variation like dirt for instance) is a better approach.

This doesn’t work for all textures. I think the issue I sometimes run into is that textures I don’t want to get destroyed by mipmapping, when the object is at a distance get blurred far too much, and for some reason the engine doesn’t switch those objects to the higher resolution when up close. When this happens, and my object (in this case a character that looks completely blurred up close) I find the texture map in UE4, and then at the Level Of Details, where it says Mip Gen Settings, I turn mipMapping off by setting it to NoMipMaps.

I wouldn’t recommend doing this for everything in your game, as it helps to keep the images cleaner when farther away, and help reduce the overhead you carry in the game during game play.

Keep in mind for my game too, I am trying to create a game that still looks very textured even when I have the Engine Scalability Settings setting the Texture quality to Low. So overall, I am trying to crunch my textures to keep my game running at a decent speed, but then I pick a couple things and turn off the mipMapping (although I’m skeptical that this always works - sometimes it ignores my setting and I’m not sure if it’s getting an override from the Scalability settings, but it’s currently unclear since it comes and goes).

-finn