Download

Texture Error in Master Material after Datasmith import from SketchUp

Hi,

When I import my model with applied textures from SketchUp to Unreal with Datasmith none of the textures are show up. In the Material Editor I get the error message “sm5 node texture sample 2d param 2d requires texture2d” (see attached picture). What can I do to use textures? Am I doing something wrong?

I’m using UE 4.21.0 Preview 4 and SketchUp Pro 2018 on Win 10
Hope someone can help.

thanks rob

Hi Rob.

I cannot speak to the specific issue, but first I strongly recommend that you update off of the 4.21 Preview and to the official 4.21.0 engine release. Along with that, make sure that you have the latest versions of both the Datasmith importer plugin in UE4, and the Datasmith exporter plugin in SketchUp.

Then try performing a fresh export and import to see if the issue still persists.

Hi Stephen,

thanks for your answer! I used the verify option in the game launcher for the 4.21.0 installation and after 5 minutes of operation and a restart of the engine the materials loaded correctly. YEAH! The label “Preview 4” was gone today without updating. :slight_smile: Idk why. You mentioned I should look for the latest Datasmith impoter plugin, but 'm not sure how I can update the plugin separately? I attached a screenshot of my current version.

cheers Rob

On the Epic Launcher, go the “Library” page, and under the 4.21 engine slot click “Installed Plugins”. For “Unreal Datasmith”, as long as the button doesn’t say “Update”…then you already have the most recent version of the importer.