Texture doesn't show at my model

So i tried to import models from h1z1 to create Killing Floor 2 map. I used ps2ls to export models (obj format) and textures (dds format), then i imported both to 3ds max and applied texture

. But after all i tried to import my model with texture, but my texture doesn’t show even after i converted dds to tga (with gimp plugin) but both KF2 sdk and UE4 shows either error or just random one color texure.

Go into your texture settings (double click on the texture in the content browser) and change the mode to “colour” :slight_smile:

Where it is?

Do you use UDK or the UE4? (because your latest picture shows UDK) :wink: -> under compression settings you should change it to colour or default

i’m using both ue4 and KF2 UDK (UE3) and most things doesn’t work if i create something in UE4 and export that to UE3, so i’d rather stick to KF2’s ue3 sadly :<

Then the best place to ask your questions would be the UDK or KF2 forum :wink: UDK - Epic Games Forums

You just showed a picture of the material editor in UE4. Please also post a picture of the UDK material editor (could be that something else causes the problem) -> but in the UE4 the compression should solve the problem

Also before you import the textures, convert them to png/tga/jpg just to be on the save side

So i tried that tip which you sent me but TC Default shows just black texture, and only way to show valid texture is to pick TC Displacementmap or TC Distance Field Font, all other shows either black texture or blue one (TC normal maps)

i managed to kinda use few textures at once, but in sdk it just shows random colors :<

Any idea? I used faces and added those textures in 3dsmax.

-either you mesh doesnt have a uv map
-you havent assigned the textures to the materials
-also make sure to import you textures as png or tga files

Alot of times you can import your own version when nothin else is there and comes out better.