TEXT() macro not displaying utf8?


This sort of thing used to work perfectly:


Now i get this result (the two first special characters seem to be ignored):


I haven’t been using special characters for a while so i don’t know in which version the problem arrived, but i’m pretty sure it once worked.

Did anything change in the TEXT() macro usage ?



you need to do:

FString test = FString(Text("YourText"));

Thanks, but same result unfortunately.

You sure your code file is encoded properly?

Could it be that the font you’re displaying the characters in doesn’t have those characters?

that’s the internal engine font though. doesn’t it have them?

That was it, well done and thanks a lot :slight_smile:

For anyone arriving here, i didn’t quickly find a way to reencode the cpp in utf8 in VS so i did it in notepad++.

I’m using a custom font but it contains all the characters, so that wasn’t the problem. Thanks though for the suggestion :-).

My cpp file wasn’t encoded in utf8 and that was the pb.