Text Box Events Not Firing

Hi guys,

I’m having a few issues with Text Boxes. Basically I have a leaderboard which is consisted of horizontal boxes from another widget being called from an array into the main widget that is displayed so it appears as a list.
All the text is text boxes with all but the new one being “read only” and the new high score being blank and set as the focus upon construction.

However, the text is not firing any events. Text Change or Text Commit just simply is not firing. I have plugged in a print string into both events and neither of them are firing ever.
It is definitely the correct text box as it is the same text box that is being set as not “read only” and set as the focus. Simply none of the events are firing.

It probably defaults to default which is close to losing focus, try it with enter:

Do note this method is somewhat special; it can fire twice - enter-commit in an empty field will fire both onEnter & onCleared if I remember correctly.

I have tried the switch with feeding all outputs into a print string, I have tried it without the switch and just feed the TextCommited event into a print string.
I have also tried just simply plugging a TextChanged into a print string and none of the print strings are firing, implying the event is simply not firing at all.

I also noticed in your example you are using an editable text rather than simply a text box, what is the difference between the two? As they both are described as doing the same thing.