Text and String variables stopped working after upgrade to 4.14

Since i’ve upgraded the project to 4.14 text and string variables stopped working properly.

Steps i’ve tried to resolve this
Change var to string or text and vis versa
Get var via Text Get function or via Variable
Integer variables just work fine, it is also np to display strings, unless they are obtained directly. All the rest of the entire data fetched and put out, just works fine, it worked fine, never was an issue before upgrade.

There is a function in below video which fetches data string from Gamesparks, it works for the integer values, np. Just not the fetched player character names, the database contains character names, Player1 is a default setting.

Video of the issue - YouTube

So, I’m also using GameSparks. It is not up to date in 4.14. Not saying they are the cause, but hopefully you submitted a ticket with them also.

If for whatever reason BPIs were broken in 4.14, you could try out Event Dispatchers as a temp or permanent solution.

Upgrading from one version to another, especially using plugins that have not been updated to the newest version can come with a lot of problems.

4.14 GS SDK has been released yesterday.

The issue is related to the new Gamespark SDK release. Feels like i am the only active Unreal user over there, since nobody else responded, haha.

A fixed version has been uploaded to the GS SDK page.