Testing Audio In Multiplayer

My project:
UE4 C++ project in editor version 4.24.3
Using Wwise Integration - Wwise version 2019.2.0
Using Windows 10

My question has to do with testing audio in more than one client in a PIE session. Namely, it is difficult to test audio from one client’s perspective because the audio focus switches when the client’s focus switches. This means, you will always only hear the audio from the client’s perspective you are controlling. Which is not what is needed when testing spatialized audio in multiplayer.

Back in 2015 a console command ‘SoloAudio’ was implemented to keep audio focus on one client. You could enter ‘SoloAudio’ in the console and it would only register audio from that client, no matter which client had focus. It appears that 5 years later, that console command has now become defunct and does nothing.

In the Windows mix console, windows just uses a single bus and switches it whenever the player switches client focus.

I have played with all of the advanced multiplayer settings in the editor and found no solution. Any tips for how to solve this problem in 2020?

Thank you.

SoloAudio is a console command for the native Unreal Audio Engine. It has nothing to do with WWISE. You should reach out to AudioKinetic to see what they recommend.

Thank you Dan. After doing some asking and also speaking with our own programmers I have found 3 solutions for others to try if they find themselves in the same boat:

  • Open the advanced settings in the Play menu. In the Multiplayer Options section uncheck ‘**Use Single Process’. **After doing so if you start two clients in a PIE session, one of them will open in standalone. This will take as long to load as it normally takes to open the editor for your project. However, the advantage of this is your editor client and the standalone client will have separate outputs in the Windows 10 Mixer. You can now mute one of the clients in the windows mixer, or mute one of the clients from yor in game audio options if you have them set up. This seems to be the best solution so far.

  • Start a PIE session with two clients. Start a profiling session in Wwise and solo one of the listeners. I found this method to be only marginally successful. I didn’t spend a lot of time with this but after a brief period of time Wwise started to choke and sputter.

  • If you have the benefit of a dedicated programming / engineering team, have them set up a console or key command that will block a client from sending any AkEvents to Wwise. This is obviously the more convenient, but more expensive route in terms of programmer time.

Hope this helps someone else out there!

1 Like

I did this but I cant see any change in the ‘Volume Mixer - speakers’ (Windows 10 mixer). The number of application and there corresponding audio input sliders remains the same. i.e there is still only one UE input.

What did I do wrong?

Try expanding the client subsection (in Advanced Settings) and ensure ‘Create Audio Device for every player’ is True

Thanks for the reply. Your totally right. It worked Thanks :slight_smile:

Great, glad it helped - good luck