Download

Terrible Documentation: Morph Targets

Right here: https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/MorphTargets/index.html

I can’t get Morph Targets into UE4. There are no errors at any point to tell me what’s happening.

The documentation is the worst I’ve ever come across. I’ve wasted hours trying to get it to work and it simply doesn’t and there’s no instruction and no one on the forum knows how to do it.

It starts by telling me how to make a Morph Target in Maya. Great. Except if I’m there, I probably already know. Make a separate documentation for that (or just remove it because this pertains to Maya not UE4).

Then it goes on to tell me how to export them. Except, everything I’ve found online seems to think I need animation set, and at this point if I don’t need animation set then it’s plain broken and Morph Target’s can not be sent from Maya to UE4. There’s a massive hole in the documentation.

Having followed it multiple times and attempted to read into everything there in every way possible and make every guess/assumption about what is said and still have no movement in getting my morph targets into UE4 which should be a simple straight forward process I can only conclude that you’re trying to set a record for either bad documentation or bad functionality.

I’ve made a post days ago on how to do it and no one’s replied. I have things I need to get done and I shouldn’t be brick walled by the most basic of things.

At no point in the process is there ever an error or means to troubleshoot this. In fact, it probably doesn’t need troubleshooting it probably just needs documentation that actually tells you how to do it.

Hi Vaei,

Man it sounds like you’ve hard a rough time with it! :confused:

I’m sorry that it’s not working out that well, but I’m glad to offer some pointers and help you get started. I’ve worked with Morph Targets quite a bit from 3Ds Max to UE4.

I’m going to list the steps I use, I know this may be a bit redundant with what you already know and may pertain only to Max for the first couple of steps, but it should work. If not I’ll help you until it’s figured out. :slight_smile:

  1. Create your mesh you want to be a morph
  2. Create a several copies and deform or adjust their verts
  3. Apply a morph modifier to your base mesh
  4. Set your morph meshes in the modifier to carry over to the base mesh
  5. Use the timeline to animate the morph meshes to your base mesh
    (FBX export should be nearly identical)
  6. Export your Morph Target mesh.
  7. In the FBX settings make sure that Animation is set to export with your morph target (Morph Targets will not work otherwise)
  8. Import the morph target FBX into UE4
  9. Import Options that must be checked: Import Morph Targets and Import Animations

These are the steps that will get your morph in.

While I can understand the confusion that you may not think you need the animation set to be included this is needed because these are still skeletal meshes and they are being animated. Instead of the animation being a single animation, we have access to the the morphs directly in the animation asset.

If you open the animation asset you’ll be able to see each morph target slider that can be adjusted for each morph that was baked. Give this a shot and let me know if this works out for you.

Also, you make mention of a post that was not responded to. Is this on the forums or the AnswerHub? Would you mind linking it here and if you’re still needing help we can carry on the conversation there to get you sorted out. :slight_smile:

Thanks, Vaei!

Tim

Thanks for your willingness to help.

It is not possible to import an exported morph target into UE4. It will error:


FAILED TO MERGE BONES:

 This could happen if significant hierarchical change has been made
 - i.e. inserting bone between nodes
 Would you like to regenerate Skeleton from this mesh? 

 ***WARNING: THIS WILL REQUIRE RECOMPRESS ALL ANIMATION DATA AND POTENTIALLY INVALIDATE***


If ‘yes’, it will want to add the morph targets as if they were bones, and that is obviously a bad thing.

Edit:

The documentation says to export the base mesh + skeleton. You say to export the morph target. Neither work.

You say to animate the morph target, the documentation doesn’t.

There needs to be a clear guide on this because whatever the process is, it isn’t transparent.

Edit2:

You do not say to bake the animation in your listed steps either, or to tell the exporter to, but then you later refer to the baked animation. Not that baking it or not makes any difference.

Oops! Let me clarify one thing as well.

When you are making the morph target what are the intentions for it? will it be part of a character or a mesh by itself that will use morphs?

I’m not an animator and have a little experience with it, so I only know some basics about character rigging.

The example I was using was assuming, probably bad on my part (durrr!), it wasn’t associated with a character rig.

So a couple of things. The documentation would be correct if you’re goign to have the morphs be part of the character, like facial morphs for instance. If you want to do the standalone mesh that has no bones and will use the reference pose as the bone then use what I listed above.

Also, what version of the editor are you using? I know with 4.5.1 the morph targets were not importing correctly due to a mistake when the import options menu was redone. No Morph targets could be imported without having at least one skinned bone. 4.6 fixed this oversight.

If this doesn’t work, I can set up two simple examples tomorrow with a skinned bone and one without if you’d like.

Thanks!

Tim

Well that explains some things… :slight_smile:

It is for a playable character. The morphs add options the player can use to customize their character - such as making him fat.

Initially I was using 4.5.0 (not 4.5.1), then 4.6.0, now I’m on the 4.7.0 preview.

I could provide the character file if you want, for the example? Particularly if it will help get it done sooner hah.

I was with you on this one. It was buggin’ me quite a bit until the fix went through! Typically most morph targets I’ve used with testing or in my personal projects have been just a mesh and not character related. :slight_smile:

If you want you can post a link here or send me a link via a private message. It’s getting a bit late for me, so no promises on an answer tonight, but I’ll look at it as soon as I can. :slight_smile:

Tim

Thank you for your help, Tim!

I flicked a PM your way. This was solved in PM so I will highlight the relevant points.

For other people with similar issue read carefully:

  • The blendshape node can NOT be referenced. The file that the blendshapes are exported from must be the final stage and the blendshape should be created immediately prior to the export!

  • The documentation says you need to export the base mesh(es) and the skeleton. It says you can delete the blendshape target after the node is created. These are both incorrect! You must export every blendshape target (the sculpted shapes that it blends into) along with the base mesh(es) and skeleton or it will not work.

It is true that Maya’s blend shape node functions without the geometry in the scene, however UE4 requires that geometry to exist in the exported file.

Again, thank you Tim, I know you went out of your way here and I appreciate it! That’s a relieving ending to a long day.

It was no problem at all! I’m glad you got everything sorted out and working in the end. :slight_smile:

Tim

The Epic crew on Twitch once joked that they should add a Clippy agent and I’m starting to think it would be a good idea.

“Tink Tink”

“ I see your trying to set up the best lighting solution ever. Can I make a few suggestions?”

Hello there,

I am with UE 4.6.1

I also have a problem with morph target, Actually I have done a heart, animate with morph target with 3ds max, so it’s simple morph and I don’t have any bones or skin just a simple morph target modifier with animation.
I really try to fallow the documentation, but I only get “Failed to find any bone hierarchy. Try disabling the “import as Skeletal” option to import as a rigid mesh” but If I disable “Import as Skeletal” I don’t have “Import Morph Target” anymore.

I have tested with a simple box too and I get the problem.
I am not sure to understand, do I need skeletal mesh for morph target (without any bones and skin) ?
Do I need to export first my mesh without morph and then export my mesh with the morph ?
Do I need to select when I export only the mesh with morph modifier or also the mesh that are the reference for the morph animation ?

Sorry for my question is the first time I use animation.

Thanks
Fabien

Hi Fabien,

I’ve setup a simple video just to demonstrate quickly the import process. This is assuming you’ve already set up your morph with no bones and just want the morph animations.

No need for skin or bones with morphs if you don’t have a need for them. Just setup the morph properly and export to FBX with animation checked.

Here are the options I use to import these types of morphs:

  • When you import make sure Import as Skeletal, even if there is no bones
  • Check the option for Import Morph Targets
  • Check the option for Import Animations.

I leave everything else as default.

No need to do that.

You only need the mesh with the morph modifier. The references are no longer needed. I wouldn’t delete them in the even you need to further edit them, but they aren’t needed. Just use the Export Selected option from 3Ds Max.

If you’re still having trouble feel free to ask questions. I don’t mind helping. :slight_smile:

Hi Tim

Thanks a lot for the video. I watch it and let you know.
And thanks for this clarification that helpful.

No Problem! :slight_smile:

Let me know if everything works out.

Hi Tim
Sorry for the delay.

So I did what I see on the video, but it didn’t work:(

I also did a video to let you see what I have done.
I don’t see where I make a mistake, maybe you will see it.

Thanks

Actually looking at this. That was actually a known issue with 4.6. For some reason I had thought that was fixed for that version, but I just tested it and that part is broken. This has been fixed with 4.7 though (the version my video uses) and this process does work.

Apologies for taking a couple of days to get back to you on this one.

Ok Tim, don’t worry for the delay, I understand.

I will test 4.7 to see, as I have a low connection actually is not for now but I believe you ^^.

Thanks a lot

Hi Tim, I come back here because I just downloaded the 4.7.6 and try again, but is still doesn’t work.
Do you have another solution ?

Thanks

Oups, my bad actually I didn’t lunch really the 4.7 but still the 4.6
So I confirm it work when I import with the 4.7