Terrain looking too shiney


When I have created my material for the terrain, it still looks very shiney, I have added a constant in and connected to the metallic and no matter what I set the figure at whether its 1 or -100 and rebuilt all the grass still shines, any ideas

Did you add a constant to roughness and set it at around .65. Make sure our metallic is set lower than that, somewhere in the .35-.55 would be a good range. You could also put in an add connected to the green of your base texture and add the roughness constant to the second connector of the add, then tie that into your roughness. That should get rid of the shine. Hope this helps.

Hi, thx for the reply I will give that a go and see what happens

Metallic should be set to 0 (or left disconnected as the default is 0) since grass isn’t metallic.
Roughness is generally what makes it shine or matte. The higher the value, the less shiny it will be however, it is better to use R or G channel of Albedo as roughness and modify it using Power and Multiply nodes since it’ll have some variation in it.

Metallic should be 0 unless the surface actually is a metal.

Besides higher Roughness value, you can also try lower Specular value at the same time - I remember that once I’ve had a terrain material with high roughness, but it still had this weird brighter shine. Setting Specular to 0 eliminated that. Maybe that was a bug or maybe it still works this way, worth checking.

The specular value represents how much light is reflected and roughness determines how that light is distributed across the surface.

Depending on your landscape material target you may actually want some specular. Plants in particular are pretty good at reflecting and diffusing light, “oceans of grass” in a sunset comes to mind.

I have deleted the Metallic, as you say grass is very rarely shiny, I have increased the roughness to 3 to see if that makes any difference. One think I have noticed, is the reflection of sun light, will that have anything to do with it?

Yep, removing the Metallic and increasing the roughness worked, will just have to play around with the roughness, thx guys been a great help.