Download

Temporarily Unlock Landscape actors in level?

Hi gurus, newbie here hoping to get some answers on this insane engine…I’ve asked this on the AnswerHub but got no answers…

I’m relatively new to UE4, currently using World Machine to generate some addon landscape features such as hills and mountains. But I noticed every time I wish to move my landscape actor, I need to manually right-click > Transform> uncheck Lock Actor Movement. After moving my landscape in only ONE action ie. move it to the right, it gets locked again and I need to manually unlock it every time. Is there a way to disable this ‘auto-lock’ feature?? I know it’s there to prevent me from accidentally moving my landscape but I need to rearrange my landscape actors often. Help?

Here’s the link to my original post https://answers.unrealengine.com/questions/276565/temporarily-unlock-landscape-actors-in-level.html

-how have you imported the landscape?
-probably you mean the grid snapping -> in the top right corner of the viewport you can choose other values/disable it :slight_smile:

  1. I imported it simply by using the heightmap generated from World Machine, then select a level > Landscape > New Landscape > Import from File > Select heightmap
  2. Not that unfortunately, what I meant was when I select the landscape actor, my cursor turns to a crossed out circle and I can’t move or rotate unless I untick ‘Lock Actor Movement’ under Transform. The only problem is after I release my mouse button it locks itself again. :frowning:

@fighter5347 WHOA I did not realize who you were until I checked out your sig! Just watched your videos and subscribed even before I posted on here! Nice vids helped A LOT! Just like to say thanks!

Hey, I know this is an old thread but just in case people are still surfing the net looking for answers, all you gotta do is go over to your “World Outliner” and right click on your “Landscape” (NOT THE GIZMO) and go down to "Transform and go down to the bottom and uncheck the box that says “Lock Actor Movement”. Hope this helps someone.

Sir, you did indeed help someone!