Download

Temporal Anti-Aliasing on Emissive Materials

Dear everyone,

since I ported our project from 4.26, I have strong ghosting on Emissive Materials.

Is the Velocity for Emissive Materials missing? I would switch on ‘Output Velocities’ for the Material, but this is only available for Translucent Materials and this is a simple Mask.



The waves emitted on the top right at the beginning are actually kinda cool^^


(The velocity buffer, doesn’t show a lot)

If you are using Lumen, ghosting is one of the things they intend to improve for release.

No, none of these settings makes a difference

That’s what I’m saying, it’s a known issue in UE5. It needs to be fixed by Epic.

It doesn’t seem to be Lumen related.

Do you have a source for the known ghosting issue?

On emissive materials: https://youtu.be/QdV_e-U7_pQ?t=3756

Lumen’s Final Gather can add significant noise around moving objects and is still under active development.

Don’t remember where they said specifically about improving ghosting for release.

I did some more testing, including deactivating Mesh Distance Fields (Lumen completely deactivated) and Forward Rendering (which worked better)

In the end it still seems like that the Velocity is not coming through for (Emissive) Masked Opaque Materials.

Luckily I now found a workaround by Setting the Emissive Materials to Translucent and checking ‘Output Velocity’.