Download

Template mobile game package fails

Hello,

I am having issues getting my android game to build. To verify it wasn’t my game, I made a template project (flying) and tried to build it but it will not build either. I followed the Android Quick Start document perfectly then began trying other things to see if I could solve the problem. Unfortunately, I don’t know much about Android development so I’m hoping someone can give me a hand. Most of the error messages do not have any information with them to help me determine that problem.

Here is my current settings for Android in the editor:

I also attached my output log.

Error: Target id ‘Android-24’ is not valid.

You need to install SDK Platform Android-24. I’d recommend setting NDK API level to android-19 and SDK API to latest; you should have SDK 19 from the installer already.

Oops it looks like I may have confused which logfile to upload. Below is my latest output log file, using ‘android-19’ in the NDK API level box.

I’ve reinstalled UE4.15 and codeworks, created a fresh project and tried to build it with out any luck. I’m pretty stuck on this one.

The problem is with JDK and ANT, look global parameter in windows like JAVA_HOME.
https://answers.unrealengine.com/questions/202561/ue-472-cant-pack-apk-with-ant.html

Hey thanks for the reply. I looked into my global parameters and found JAVA_HOME. I don’t believe that is the problem. I wish the problem were a simple space in the file name though, that seems to be a lot of other people’s problem!