Teleport Malfunction

Have a project well working on 4.9.2 with “goto” menu sending the third person character to several locations with teleport command in a blue print. Now with 4.10 release teleport returns false in specific combinations of current / next location and on some tegets crashes completely.
Is this a bug when all ever worked fine on 4.9.2 ?

Hello shauki,

Could you provide some screenshots of how you have your blueprint set up for teleporting the character? Also, can you attempt to recreate the setup in a 4.10 project without converting it from 4.9.2? That way we can tell if it is an issue with converting a project, or if the setup is just not functioning properly in 4.10. Thank you.

Here are the screenshots. Redoing in 4.10 from scratch can only end of November coming back from the vacation :slight_smile: Thanks.


I wanted to check with you to see if you’ve had a chance to attempt to reproduce this issue in a clean project. If so, have you been able to determine the repro steps necessary to get this issue to occur? After some testing, I’ve been unable to experience the same behavior that you’re seeing.


I am marking this post as resolved as I have not heard from you in a few days. If you are still experiencing this issue, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day,

Sean Flint

Sorry for late answer. Have no window to recreate in a new project. With 4.10.1 old project just crashed and I sent the error report adding the link to this post in description field

Could you reproduce the crash and provide your Machine ID that is listed in the Crash Reporter window?


Since we have not been able to reproduce this issue internally at this point, would you mind zipping up and uploading your project to Dropbox and providing a link so that I can attempt to test the issue in the project where it is occurring? Thank you.

target_slewing is not a narrow area but it does not teleport to it.
Ok, cabin does not crash by relocating, but did not teleport to it too.
If it teleports to all locations in your project may I have it, please?

I’ve noticed that some of the Target Points, especially the one in the cabin, were in spots that were too small for the character to teleport to. The entry to the loader was another one of these, so go ahead and try to move your target points around to more open areas. Once I moved them around, I was able to get all of the teleport locations to work without a problem.

I placed the target point for the cabin just above the cabin, or you could also try to increase the size of the cabin in order to allow enough space for the character to fit. I took a look at the Target_Slewing point, and it does seem to be actually inside of another asset.
When you teleport to a target point, the center of your character is going to teleport to where the point is located. This means that you will need enough space both up and down for the character to fit in the area that you are attempting to teleport to.

Got your point. It works! Thanks!
But, why is this change at all ??
Maybe worth to revert?..

There were some bug fixes regarding teleporting from 4.9 to 4.10. Technically, your teleports shouldn’t have worked in 4.9, because the target points were in areas that were inaccessible (meaning there wasn’t enough space for the character to teleport to). So it is very possible that the behavior you were experiencing in 4.9 was in fact a bug, and with the update to 4.10, the bug was fixed which prevented these locations from working without adjustment. I hope that helps.