Download

TC: Setting up default pawn class

So, I was all excited to come home and spawn in as a dino. This should be really simple with the way UE4 is setup, and given that I now have the ability to override the game mode. Nope. I set everything up just like the simple instructions outlined, but, when I spawn in my default pawn does not change. To test and see if it actually changed my game mode, I went in and and changed the experience required to level just to see if I could quickly change something. Worked fine.

Has anyone successfully overwritten the default pawn with anything? This is super duper frustrating.

currently working on making it a dino lol but i made a child of the base human test pawn, and set its third person view model to the dodo model. I can run around as the dodo as long as i leave the animation blueprint as none, but ofc there is no animations. If i set the animation blueprint to dodo blueprint, the dodo will stay in idle animation and the dodo mesh wont follow the player pawn, it stays in coordinates 0,0,0

wonder if it has be a certain pawn class, hmm

are you able to do it inside the editor? i’m cooking it right now to see if it works in game

yeah in editor havent tested actual game but i run my editor as dedicated… i been waiting on the update so i can finally go through some of there basics and make a new character chooser (dinos vs ppl) well 2 ways u can either do it off the male/female causes minor weird things or off the default pawn the character base thingy lol

How did you setup the game mode? Did you set the primal game data in your level, and set the game mode inside there? Or did you directly set the game mode override in the level? Or both? I tried every combination to no avail :frowning: it almost seems like the game load doesn’t work but the primal game data does. Is there a check box to tell it to override the game mode? Should just pick up on it, no?

uno how the generic mod is hooked together? gamemode tells gamedata that then feeds into the lvl

yeah memory leaks are a given sometimes u may have hooked something up wrong ect really it can be anything i got a post for things im trying to help with in ark support (no link ppl sooking) but as soon as the devkit updates ill get back onto finding out/posting up helpful stuff

Yeah, can’t launch anything now, just takes up all my RAM and crashes. Sigh… Frustrating is no longer the word to describe this. You don’t know how many bad things I want to say right now :slight_smile:

i no exactly how u feel trust me :slight_smile:

go into the explorer and delete whatever u just made if u cant launch i have done this to myself many times lol

once we get the whole thing working properly we will be linking the assets as a base so ppl know the basics but it could take a little bit its alot more complex than it looks lol

Yeah I literally just deleted all my content, verified the files and when I load genericmod, I just crash. I can load the test level fine, but not the generic mod.

I’m just going to wipe out the entire arkdevkit folder and download it again. Getting kinda ridiculous.

thats weird i havent had that problem yet i have a “test”, “tested”,“working”,“current” and “upload” folder just so i dont ever stuff myself over all had either the generic mod default or testmap with the default generic gmbp

Yeah I’m going to have to make a copy of this once it’s done and put it somewhere. Of course I think of these things after the fact.

always better to be safe than sorry especially with blind modding anything u do can have unexpected results have backups and save often :slight_smile: