t.MaxFPS doesn't work when window is resized

Hey!

I’m having a problem when changing the maximum FPS of my game. I’m using node to execute console command (“t.MaxFPS 60”) in the Blueprint of the level.

When I export the game everything goes fine. I use the “stat fps” to see the FPS and it stays at 60. But when I do a resize of the window the maximum is removed.

I would appreciate help. I am using UE 5.0.2.

Cheers!

I don’t know for sure, but I think the console command does not actually save the setting to GameUserSettings, as opposed to GetGameUserSettings()->SetFrameRateLimit(), so when you change the window mode, the actual GameUserSettings kick in and return the frame rate limit to what is saved in the settings.

Instead of a console command, try GetGameUserSettings()->SetFrameRateLimit(), and then ApplyNonResolutionSettings().

2 Likes