t.MaxFPS 0 locks framerate to 120fps for some inexplicable reason

Despite the CVar description stating otherwise, if you type t.MaxFPS into the console with ‘0’ as a value, then FPS is clamped to 120.

I can call t.MaxFPS 500, and hit framerates of about 200-250 in our game, so no idea where the 120 limit is coming from.

Hey I was able to reproduce this. I have logged it into Jira as a bug report and that number is JIRA UE-52091. Our Developers will investigate it further so please refer to the link for updates.


Ran into this and discovered that the 120 is coming from the default SmoothedFrameRateRange in BaseEngine.ini. The project’s smooth frame rate option will be in effect if enabled and t.MaxFPS is 0. When t.MaxFPS is non zero, that value is used instead of the smoothing range. The logic for this is in UEngine::GetMaxTickRate().