System cursor changing fail

Hi! I made simple things to change system cursor from arrow to hand. So when I’m pointing to one (door with cloth) object everything is fine, but on the same location when i’m pointing to another object (wardrobe) cursor doesn’t want to change, while during debugging it shows that nodes are firing well. I’m using the same nodes and over cursor events in both objects.
Probably I’m doing something wrong, any advice needed. Thanks!



Hello ,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?
  3. Could you elaborate on what the mouse is supposed to be hovering over as shown in your screen shot?

Hello Rudy! Thanks for answering!
I tried to reproduce this issue in 2d platformer template, and unfortunately wasn’t able to make it) What I did there is just made one actor with cube and collision box in it, and adjust collision box like this:


And it worked fine, when i’m hovering either box or cube cursor changed to “hand”.



Actually the same things I made in my main project. I’m using collision box to check what cursor to set. And one more thing: for example I made “door” to another room, it’s an actor with just collision box in it, when mouse hovers it cursor should change to hand, when I’m clicking it we are going to another location. When I just made this actor everything was fine, but as I played a little changing cursor stopped working.
I’m sorry for little information I can provied.

I noticed that you said you were unable to reproduce this in a clean project. Would it be possible for you to provide the project that is having the issue?

Yes, sure, thanks! )
You can take development build from here:

And source project from here:

Hello ,

I tried to access the projects provided however the links in your last post did not appear to work. Could you provide the project via google drive or drop box?

Ooops, I’m sorry about that.
Development package here:

Source of project here:

And one more thing I wanted to add about this cursor failing: I’ve noticed that it works fine when I’m hovering an object that was last modified. As I wrote above: I had two objects (actors) ‘door’ and ‘wardrobe’ so if I just rename collision box component in any of them, that actor which was modifed the last will be working fine.

After looking through your project I have a test I would like for you to try. Could you please try going into your “DoorToKladovka” blueprint and enabling input from the player controller?

Hi Rudy! Thanks for helping!
I did as you advised, but unfortunately it didn’t work. Or I’m missing something?


I took another look at your project and I did a bit more testing. I was able to find that your issue appears to come from the fact that you are setting the cursor on tick. I removed this from both the “DoorToKaldovka” and “Shkaf” and instead I used the setup provided below. I hope that this information helps.


As you can see I removed the tick that was being used for this part and I have used the mouse over events to set when the mouse changes.

Make it a great day

Thanks a lot that realy works! :slight_smile:
But I can explain why I used tick event. For example my character is away from the door, so I’m clicking on that door and while he moves to it I’m hovering the door, and when he get close to it and the cursor has to change it doesn’t. I need to move cursor out of the collision box and then move it back to get right cursor.