Sync with Archicad now crashes Twinmotion

I have posted a bug report, and about 30 crash reports. I have also tried to contact support, but they keep referring me to a webpage that does not offer tech support. At least 3 different people have told me the same. They don’t even bother to read the question properly. I am extremely frustrated.

I started a project in Archicad 22 6021 and linked it to Twinmotion 2019.6. I had successfully completed numerous synchronizations without issue. On October 30, TM started crashing at the finalization stage. Below is from the crash window:


Access violation - code c0000005 (first/second chance not available)

Twinmotion_Win64_Shipping!CTwinmotionReceiver::unregisterData() [x:\twinmotion\project\source\twinmotionaddin\private\twinmotionreceiver.cpp:4005]
Twinmotion_Win64_Shipping!CTwinmotionReceiver::cleanupUnusedMaterials() [x:\twinmotion\project\source\twinmotionaddin\private\twinmotionreceiver.cpp:4515]
Twinmotion_Win64_Shipping!CRestoreMaterials::synchronize() [x:\twinmotion\project\source\twinmotionaddin\private\task\restorematerials.cpp:19]
Twinmotion_Win64_Shipping!IBaseTask::update() [x:\twinmotion\project\source\twinmotioncore\private\task\basetask.cpp:152]
Twinmotion_Win64_Shipping!CTaskManager::update() [x:\twinmotion\project\source\twinmotioncore\private\task\taskmanager.cpp:159]
Twinmotion_Win64_Shipping!ATwinmotionGameMode::Tick() [x:\twinmotion\project\source\twinmotion\private\twinmotiongamemode.cpp:228]
Twinmotion_Win64_Shipping!AActor::TickActor() [x:\engine\engine\source\runtime\engine\private\actor.cpp:870]
Twinmotion_Win64_Shipping!FActorTickFunction::ExecuteTick() [x:\engine\engine\source\runtime\engine\private\actor.cpp:137]
Twinmotion_Win64_Shipping!TGraphTask::ExecuteTask() [x:\engine\engine\source\runtime\core\public\async\taskgraphinterfaces.h:829]
Twinmotion_Win64_Shipping!FNamedTaskThread::ProcessTasksUntilQuit() [x:\engine\engine\source\runtime\core\private\async\taskgraph.cpp:573]
Twinmotion_Win64_Shipping!FTaskGraphImplementation::WaitUntilTasksComplete() [x:\engine\engine\source\runtime\core\private\async\taskgraph.cpp:1355]
Twinmotion_Win64_Shipping!FTickTaskSequencer::ReleaseTickGroup() [x:\engine\engine\source\runtime\engine\private\ticktaskmanager.cpp:542]
Twinmotion_Win64_Shipping!FTickTaskManager::RunTickGroup() [x:\engine\engine\source\runtime\engine\private\ticktaskmanager.cpp:1449]
Twinmotion_Win64_Shipping!UWorld::Tick() [x:\engine\engine\source\runtime\engine\private\leveltick.cpp:1429]
Twinmotion_Win64_Shipping!UGameEngine::Tick() [x:\engine\engine\source\runtime\engine\private\gameengine.cpp:1266]
Twinmotion_Win64_Shipping!FEngineLoop::Tick() [x:\engine\engine\source\runtime\launch\private\launchengineloop.cpp:3339]
Twinmotion_Win64_Shipping!GuardedMain() [x:\engine\engine\source\runtime\launch\private\launch.cpp:166]
Twinmotion_Win64_Shipping!GuardedMainWrapper() [x:\engine\engine\source\runtime\launch\private\windows\launchwindows.cpp:144]
Twinmotion_Win64_Shipping!WinMain() [x:\engine\engine\source\runtime\launch\private\windows\launchwindows.cpp:223]
Twinmotion_Win64_Shipping!__scrt_common_main_seh() [d:\agent_work\1\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl:288]

This has happened well over 20 times now. I have updated windows, my graphics card, followed the steps on the TM website about what to do for a crash and nothing has worked. The various logs I can see change each time offering slightly different results. I even tried to install a new instance of AC 22 on a spare computer and a new instance of TM. Same exact issue. I also tried installing AC23 and trying to sync that way. Same issue.

From the CrashContesxt.runtime-xml file I noticed this: Twinmotion_Win64_Shipping!CTwinmotionReceiver::unregisterData() [x:\twinmotion\project\source\twinmotionaddin\private\twinmotionreceiver.cpp:4005]

This also appears in the crash data I pasted in above. I don’t want to start over only to have this happen again. If anyone knows how to cut and paste twinmotion objects etc. from one project to another, that would help. Or at least if I could delete the linked Archicad portion and reimport as an FBX. The linked portion will not go away. Someone from Epic should monitor these forums and provide suggestions if they are going to offer no other support. I’m extremely disappointed. Have I said that enough times Epic?

Event this forum doesn’t give you an option to post for Twinmotion. Lame!

I’ve solved this issue. You need to create a new folder someplace convenient that is different than the location of your file. Then open up the TM file that keeps crashing, and goto Edit, resource collector. Make sure you have the Collect TM option set. When it is finished, it will create a folder with all the textures you had in that file, plus a TM file of the same name. Now open a new blank TM file. Goto your Archicad file and hit the DirectLink again. When the focus changes to Twinmotion, select Existing Project, and then navigate to the folder your created and select that TM file. Select force sync when prompted, and Bob’s your uncle. Hope this helps others.

This works!
I had the same issue and this made it work.
Thank you very much!