Symbol lookup error: /usr/local/share/UE/UnrealEngine/Engine/Binaries/Linux/ undefined symbol: _ZTV23FMaterialEditorCommands

Suddenly, the error “symbol lookup error: /usr/local/share/UE/UnrealEngine/Engine/Binaries/Linux/ undefined symbol: _ZTV23FMaterialEditorCommands” appeared when I tried to compile my project.
After a lot recompiling, I decided to remove my 40 GB git checkout of Unreal Engine and clone a new version. Afterwards, as always:

cd /usr/local/share/UE/UnrealEngine/

Then, I openen my project and tried to compile it again, which failed. I tried to start


without any parameters but the error reappeared. Any idea why?

Hey thecr3w-

Are you still seeing this error when compiling your project? Are you able to compile other projects or do you get this error with any project? If possible, can you let me know if the same issue occurs with a 4.15.1 project?

I also encountered this error when compiling an Unreal plugin, and then killing command in the middle of the compile. The next time i restarted Unreal, i got that error message.

Hey -

What plugin were you compiling? Can you provide the exact steps used when you ran into this?

Hey thecr3w-

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.