Switching to Cinematic camera Mode and back breaks UI

There’s an annoying bug that causing UI to “glitch”.
If View mode switched to cinematic mode, and then back to perspective, UI may be stuck at the Cinematic layout.

Clip from 's stream with this bug

Any button on this menu stopping to work.

The only restart of the Editor helps to solve.

It’s not clear what sequence of button presses triggers it, but it’s clear that first step is switching to Cinematic mode.

I’ve tried different ways, by switching to ortho views in cine mode, switching regions grids.

I’m not sure if it was reported before ( was aware of it).

It’s been tested on 4.17.0 p3 and this issue still persists.

Hello ,

I have tried running a few tests on our end and I have not been able to reproduce the issue mentioned above. Could you provide more exact reproduction steps to that I can reproduce this issue on our end?

I’ve spent like 4 reboots trying to figure out how this happening.

  1. Load any scene
  2. Default viewport type is on (on this stage switching to Cinematic only adds a film overlay button)
  3. Unfold View mode setting (maybe hover some items)


  1. Now switch to Cinematic (new navigation buttons will appear)


  1. Switch back to Default (congratulations, You’re doomed)

Thank you for the additional information. I was able to reproduce this issue on our end. I have written up a report and I have submitted to the developers for further consideration. I have provided a link to the public tracker. Please feel free to the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-48125)

Make it a great day