Download

Swimming characters and camera clipping through ceilings

I am having an issue where the camera is clipping through static mesh components above my character.

Here is an example of what I am having an issue with: (I couldn’t figure out how to attach images to the new UE forum UI, so I have external links)

Inside the cave passage:

Camera clipping through when at the roof of the passage:

This happens anywhere I can swim up to the ceiling of a cave passage or interior area, regardless of mesh or collision settings.

Here are the collision settings on this particular static mesh. All of the ones that I am having this problem with have collision enabled and set to blocking for the ‘Camera’ channel. I also tried ‘Block All’ instead of ‘Custom’ for collision presets but it didn’t change the behavior.

Last, here are the settings for the springarm component attached to the Mosasaurus, the creature I am playing in these images.

I’ve checked the settings I know to look for here and made sure everything matched collision channels properly. I’m not sure how to stop this camera from clipping through the ceilings, and enlarging the cave passages has not had any influence on stopping this from happening. I’ve looked at other forum threads, but none seemed to present a solution that works for my particular case, which is with swimming creatures hitting cave ceilings.

Does anyone have any advice on how to fix or bypass this issue?

I wanted to post this here. I finally managed to fix this issue. Here is the solution:

The springarm’s starting location was outside of the capsule.