SwarmCoordinator is only reachable with the Windows Firewall disabled

I’m trying to get our Swarm Coordinator hooked up. I’m unable to connect to the coordinator with any of the Swarm agents unless the Windows Firewall is disabled on the coordinator PC.

I’ve added the coord into the list of exceptions i.e. I have two Inbound Rules (UDP and TCP). I’ve also tried adding an Outbound Rule, but that didn’t help.

I’d like to be able to get this setup without the need to turn off the firewall, so any help would be appreciated.

I was just struggling with this and managed to solve it by allowing inbound connections for the Swarm Agent and also ports 8008 and 8009 (default ports for Swarm) I also had to allow ping which was turned off by default on fresh Windows 10 installs. This link shows you how to allow ping: http://www.sysprobs.com/enable-ping-reply-and-ftp-traffic-in-windows-10-and-server

this sucks, thank you for your answer.

It happened to me when running the program for the first time, I accidentally set it to not allow and then the swarm agent never worked again.

very annoying.