Download

Swarm won't start. Won't build lighting.

Hi.
I just recently grabbed the source code for unreal engine from the promoted branch, compiled it and I seem to work fine, except for one thing:
It won’t build lighting. Says “swarm failed to kick off”.
I’m on Windows 10 pro, compiling with Visual Studio 2015.
On windows 8.1, it worked perfectly well.
I think it started happening around the time I got windows 10.

I tried creating new projects with different templates, but the problem seems to persist.
I disabled my firewall and my antivirus completely, and it still persists.
I even tried recompiling the whole thing anew, and it won’t get it a rest.

This is what I get in the swarm log:

Let me know if I forgot to mention something.
Any ideas?

Summary:
*Swarm won’t kick off
*Compiled from promoted branch
*Problem appeared after installing windows 10
*Problem occurs on any project, not specific to a project
*Using Visual Studio community 2015
*Firewall/Antivirus disabled - still nothing.

Ok, solved.
This is rather weird. Apparently, UnrealLightmass.exe was missing! The darnest thing.
So, I went to Visual Studio and built the UnrealLightmass project, started the editor, and built it successfully.

2 Likes

Thanks!
It helped me!

For those who may have this issue where rebuilding UnrealLightmass doesnt work. Make sure you build it on Development Editor. When I only built it as Debug Editor, swarm will always “Fail to kickoff”.

I don’t know how to use Visual Studio. Could you explain what I have to do, step by step?

Open the UE4.sln in the root engine-source folder (LMBx2 and it will auto-open VS)>Expand the Projects folder>RMB UnrealLightmass>Build. I’ve opted to RMB>build the entire Project folder, just in case there are any other internal UE programs which are absent. Seems the source engine may not have all of those enable to be “lean”, although if that’s the case then it is not a good one.

There is also this documentation which is quite useful for all things Lightmass. It seems the source version of Unreal has common issues with Lightmass needing to be re-compiled.