Swarm error

I get the following error message in 4.7 builds and newer. Lights still rebuild in 4.6 or older versions Can You help with this?
: [Interface:OpenJob] Error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (Exception from HRESULT: 0x80070422)

Same problem here. Cant fix it.
Can someone help out?

Same error here. Anyone, please!

Trying to get some help here

No one yet. Help, please.

I moved your thread to the Bug Reports section so we can better track it. When posting potential bugs, please make sure to post it in the correct section so that we can quickly see and respond to it. Now, is this a C++ or blueprint project? Additionally, did you make it in the binary version of the editor or in the launcher version? Have you actually built lighting yet to try and remove the errors?

I’ve tried both the binary and the launcher version and I get the same error in every project. Although, admittedly I’ve not tried it with a C++ project, just the Blueprints one. Let me try it now and see.

I’m not able to build the light because of this error. Every time I select build, whether it is Build All or Build Lights Only, it starts the process and the stops. When I select Build Geometry I get a Map Check error saying that “Maps need lighting rebuilt” I’ve deleted the maps and click on Build again, and the same thing happens. I’ve deleted the Swarm folder, and the same keeps happening.

Thank you for replying, Adam.

Try pulling everything out of your contents folder, including the maps folder, then start the project. After this press build on the black screen you enter in on. Does it build then?

Hi Alex Tamayo,

We have not heard from you in several days. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

Adam, please excuse me, I’ve been hospitalised for the past week. I’ll get back to you as soon as possible. Thank you for following up!

Not a problem at all and hopefully you are well! I’ll leave this unanswered for now until you are able to test.

Hello Adam,

The doctor told me to take some time off the computer to get better faster. I feel much better now. My apologies for taking so long to reply.

I created a new C++ project and emptied out my content folder, in both occasions, it gave me the same error back again

I tried the new 4.8.0 Preview 2 and I get the same error.

I don’t know if this is relevant, but I’ve got quite an old machine with an Intel i7 920 @2.67GHz, 18GB of RAM and a Nvidia Quadro FX1800.

Not sure if relevant either, but dynamic shadows don’t work either.

00:22:37: Starting up SwarmAgent …

00:22:37: … registering SwarmAgent with remoting service

00:22:37: … registering SwarmAgent network channels

00:22:37: … initializing SwarmAgent

00:22:37: … certificate check has failed

00:22:37: … initializing cache

00:22:37: … using cache folder ‘C:/Users/OMITTED/AppData/Local/UnrealEngine/4.8/Saved/Swarm\SwarmCache’

00:22:37: … recreating SwarmAgent cache staging area

00:22:37: … initializing connection to SwarmCoordinator

00:22:37: … using SwarmCoordinator on RENDER-01

00:22:37: … SwarmCoordinator failed to be initialized

00:22:37: … initializing local performance monitoring subsystem

00:22:37: … initialization successful, SwarmAgent now running

00:22:37: [Interface:TryOpenConnection] Local connection established

00:22:37: [Interface:OpenJob] Error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (Exception from HRESULT: 0x80070422)

00:23:24: [Connection] Detected new local connection from same process ID as an existing one, closing the old one

00:23:24: [CloseConnection] Closing connection 20282B1D using handle 20282B1D

00:23:24: [CloseConnection] Connection confirmed for disconnection 20282B1D

00:23:24: [CloseConnection] Closing orphaned Job ()

00:23:24: [CloseConnection] Connection disconnected 20282B1D

00:23:24: [GetMessage] Safely returning to 20282B1D with no message

00:23:24: [Interface:TryOpenConnection] Local connection established

00:23:24: [Interface:OpenJob] Error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (Exception from HRESULT: 0x80070422)

00:23:25: [MaintainConnections] Local connection has closed (20282B1D)

00:23:25: [MaintainConnections] Removed connection 20282B1D

Hi AlexTamayo,

No need to apologize! Health and well-being should always take priority. Can you post your dxdiag here so I can take a look? You can find that by going to the start menu, type dxdiag into the searchbar and select the program that appears. Save that to a .txt and upload the .txt here. Thank you!

What scalability settings are you using? It looks like the Quadro you are using is below specs for what we recommend. It will still work but we cannot guarantee a good user experience. Setting your scalability settings to a lower setting may help alleviate some of the burden on swarm agent.

Scalability is all low. Although, I just noticed that real time shadows only show up when I put the shadows in epic. They’re barely visible in high.

I’m planning to buy a new GPU soon. Do you think my old GPU might be the source of my problems? I thought that since it seems to be a swarm problem, it was related to port communication/firewall problem or something like that, not with my GPU. I mean, I know my GPU is bad, but it bakes lighting just fine in 4.5 and below. Did you change a lot in lightmass’ architecture from 4.5 to 4.6? And the lag when I put everything in epic is not that massive.

Thank you, Adam, for following up, I really appreciate it. :slight_smile:

Oops! I’ve just deleted this section by mistake. My apologies.

My scalability settings are all low. Although I noticed that realtime shadows only show up when I put the shadows in epic. They are barely visible in high.

Do you think the source of the problem is my GPU? I thought that it might be something related to communication/firewall or something like that, since the problem is seemingly happening with the swarm agent. I know my GPU is bad and old, but it bakes just fine with 4.5 and below. Did you change lightmass’ architecture a lot from 4.5 to 4.6 or something? Even when I put everything in epic, the lag in the scene is not that massive.

And Adam, thank you very much for following up, I really appreciate it! :slight_smile:

I’ll be happy to let you know whether or not this error is hardware specific. If you can, please upload your dxdiag.txt here so I can take a look.

Here it is! Excuse the tardiness.

Try updating your video card driver. I noticed in your dxdiag that it seems to be a bit out of date. It may be that the graphics card itself needs to be updated as an Nvidia Quadro FX 1800 is an older card and may not be able to handle the engine as well as cards such as an NVidia GTX 460 or higher.