Swarm Crashes - Can't restore old settings

I tried setting up distributed lighting builds for my system, and now I can’t build anything (even If I disable distribution). Here are my settings (both PC’s have identical settings and are connected via LAN).

Unfortunately, whenever I try to build lighting from the editor - the editor dialog box pops up for about half a second then dissappears, and swarm doesn’t even start building lighting. I checked the log, and this is being printed everytime I run it:

[2017.09.07-09.54.03:925][342]LightingResults: New page: Lighting Build - 7 Sep 2017 11:54:03
[2017.09.07-09.54.03:932][342]LogSwarmInterface: [OpenConnection] Registering TCP channel ...
[2017.09.07-09.54.03:933][342]LogSwarmInterface: [OpenConnection] Connecting to agent ...
[2017.09.07-09.54.03:934][342]LogSwarmInterface: [TryOpenConnection] Testing the Agent
[2017.09.07-09.54.03:935][342]LogSwarmInterface: [TryOpenConnection] Opening Connection to Agent
[2017.09.07-09.54.03:935][342]LogSwarmInterface: [TryOpenConnection] Local Process ID is 6896
[2017.09.07-09.54.03:982][342]LogStaticLightingSystem: Running Lightmass w/ ImmediateImport mode ENABLED
[2017.09.07-09.54.03:982][342]LogStaticLightingSystem: Running Lightmass w/ ImmediateProcess mode ENABLED
[2017.09.07-09.54.03:982][342]LogStaticLightingSystem: Running Lightmass w/ Sorting mode ENABLED
[2017.09.07-09.54.03:982][342]LogStaticLightingSystem: Running Lightmass w/ Mapping paddings ENABLED
[2017.09.07-09.54.03:983][342]LogStaticLightingSystem: Running Lightmass w/ Mapping debug paddings DISABLED
Exception thrown at 0x00007FFB6C439E08 (KernelBase.dll) in UE4Editor.exe: 0xE0434352 (parameters: 0xFFFFFFFF80004003, 0x0000000000000000, 0x0000000000000000, 0x0000000000000000, 0x00007FFB43FB0000).
The thread 0xc60 has exited with code 0 (0x0).
[2017.09.07-09.54.04:045][342]LogEditorBuildUtils: Build time 0:00

So clearly, something related to Swarm is crashing - but I have no indication what it is. I’ve followed all the setup guidelines for distributed builds, so why isn’t it working?

Worst of all - I’ve reverted the settings, and now the Engine can’t start Lightmass at all. What’s the deal? I’m stuck an unable to build lighting on either machine now.

I’m using a source-built version of the engine (4.17.1) - so I can’t use ‘Verify’ on the Launcher.

Just looked at the Swarm Log, this is what I get

11:02:51: [Interface:TryOpenConnection] Local connection established
11:02:51: [Interface:OpenJob] Error: Value cannot be null.
Parameter name: value
11:02:51: [MaintainConnections] Detected dropped local connection, cleaning up (643BF1C2)
11:02:51: [CloseConnection] Closing connection 643BF1C2 using handle 643BF1C2
11:02:51: [CloseConnection] Connection confirmed for disconnection 643BF1C2
11:02:51: [CloseConnection] Closing orphaned Job ()
11:02:51: [CloseConnection] Connection disconnected 643BF1C2
11:02:51: [GetMessage] Safely returning to 643BF1C2 with no message
11:02:52: [MaintainConnections] Local connection has closed (643BF1C2)
11:02:52: [MaintainConnections] Removed connection 643BF1C2
11:02:52: [MaintainConnections] All connections have closed

Tried disabling Windows Firewall on both machines. STILL fails.

I removed the Options.XML files so Swarm is back to default settings - now I get the same error, so I’m stuck an unable to build lighting at all.

REALLY need a fix for this!


Still having this issue. Even reinstalled the engine.

I never managed to fix this - but I was able to get distributed builds working by following this guide. It seems to be the most up-to-date (even better than the documentation)

Since then I’ve upgraded engine versions, so sorry if anyone has the same issue in the future!

HI, I try use Jenkins to build light , get some error msg .
I just try debug swarm agent , got there are null exception at \UnrealSwarm\Agent\Connections.cs#GetProcessPathById

So It should be Privilege Limited!
see windows - wmic process empty executablepath - Stack Overflow
At Last I run swarmagent as administor