Swarm Agent waiting for remotes to become available

While trying to use remotes with the swarm agent I’ve suddenly been unable to use the server. The other machine is still able to use the server just not this one which is permanently waiting for remotes to become available. I am attaching logs. It was originally working fine, I don’t remember altering anything with the swarm agent between then and now either. Anyone have any ideas on what’s going on?

Same problem!

This solved it for me: I checked my network group. One of my machines was set to public and not home. I set both machines to home. After that, everything worked fine.

It works amazing, thanks!

For me, I have to add firewall rule for all PC as below:
Open Firewall Advanced Setting, click Inbound - “New Rule” → “Port” → TCP / Specific local ports: 8008-8009 → “Allow the connection” → (All Domains should be Checked) → Name it “Swarm Remote Ports”

1 Like