Swarm agent only builds on the coordinator's machine

We are trying to set up a distributed render on two computers. It worked for a while but now we can’t figure out what can be the problem. Here is our set up.
The coordinator sees the other computer as you can see on the picture (the groupname is the same Alma-Alma):

Here is the agent at the coordinator’s computer (we are connected through lan) :

Here is the agent at the second computer:

We tried with different computers still just the coordinator’s computer is building. If I open the Swarm Coordinator it says one is busy (which is currently building) one is available and unassigned. If I ping from a remote agent the coordinator is available. I think I tried everything but still nothing. Is it possible that we messed something up with the project? If you have any suggestion please help us. We greatly apprichiate it.

I’m trying to get the exact same thing working, and I think your “AgentGroupName” and “AllowedRemoteAgentGroupNames” settings should be the same, and the same across both computers. This is only a guess because I haven’t been able to get it working yet either, and there is 0 up-to-date documentation on how to use Swarm.

I managed to solve this by now. We are building with 4 computers right now through ethernet. I think the reauter was the problem for us but I dont really remember…

Some tips might be useful:

  • We couldnt manage to connect through computer names just ip-s maybe try that first

  • Our settings:

AgentGroupName: Default
AllowedRemoteAgentGroup: Default
AllowedAgentGroupNames: *
CoordinatorRemotingHost: ip of the computer running the SwarmCoordinator

  • You have to write the same coordinator ip for every computer (check it with cmd: ipconfig on coordinator computer)

  • If the coordinator is running and you write the coordinator ip to swarm agent and press enter you can see the computer showing up in the coordinator window immediately. Or you can check it again with pressing Network-ping coordinator in SwarmAgent. If its not showing up and not even after ping, check the log tab. It should write: Coordinator has responded normally. Else check the ip you wrote for coordinator. Usually thats the problem or something with the local network.

  • Ohh really really important: After u see all the computers showing up in coordinator, u must see AVAILABLE next to each. If a computer BUSY its not gonna build. Swarm has some safety feature that doesnt let computer build if the processor running more then x percent. So if the others working in unreal just minimise it for a moment while you start the build.

Hope it helps.