Download

Swarm agent failed to kick off. Need help

((Copy pasting this from my reddit post since no luck there))

Hello, I’m having a major issue here where swarm agent fails to kick off when trying to build lightning
I’ve been at this for hours now, been googling non-stop and trying to figure out a solution to this.
It starts “Explorting Lightning Data:” to about 64%, then it ramps up to 100% instantly → Swarm agent failed to kick off
I’ve tried
Disabling Firewall / Antivirus
World Settings / Static Lightning level Scale to higher than 1
Look for duplicated names of meshes, nothing found
Removed each and every single of my foliage
Triple checked my Harddrive space, I have 30gb on one Harddrive and 400gb on the other, Unreal and Epic games is kind of split between those harddrives in a weird way but I don’t think the harddrive is an issue
I’ve tried building lightning in another level, worked just fine
Eventually I had to at least try removing my assets because I read that it could be a corrupt mesh but really did not wanna go through everything since my level is really large. I started deleting about 15% of my meshes at a time then trying to build lightning, quit unreal engine without saving, went back in and deleted another 15% and kept doing that until I had trying building lightning without each and every one of my meshes and the problem is still there…
Thanks a lot in advance!
EDIT; Just now I tried to copy everything from my level and paste it to a new level. Then rebuild the lightning there, and it did not work… So theres still something wrong with my meshes somehow? Even tho I’ve tried deleting all of them… I dont know what to do here… Maybe I have a lot of corrupt meshes, I’ll try and delete 50% of my meshes now and see if that works then the other 50% after that…
EDIT 2; Alright so I’ve figured out that there are corrupt meshes, I tried deleting 50% of my meshes (top half) and now it worked, problem is… Theres way more than one, spread out… So its gonna take me FOREVER to figure out which ones… I will do it as a last resort of course, but does anyone have a better way? Since I have to go through about 1000 meshes now
Imgur of my Swarm error I get if thats useful - http://i.imgur.com/hWgRHuW.png

THIS WORKED FOR ME:

If you’re using 4.10 or later you will need to have the VS2015 dependencies installed.
You can download the Visual Studio Dependencies from Microsoft’s website:

VS2013: http://www.microsoft.com/en-us/download/details.aspx?id=40784
VS2015: Download Visual C++ Redistributable for Visual Studio 2015 from Official Microsoft Download Center