Swarm Agent Error/Crash When Building

Everything was going well until I tried to build my lighting at High quality.

After 30 mins of waiting, UE4 was still showing me that it was trying to start up the Swarm connection. It’s stuck at 100% and with 2 seconds left.

The editor freezes completely, forcing me to have to close it via task manager.


I have then tried build once again, but this time on preview quality, then tried medium; I still get the issue.

The swarm agent log shows this error:

11:11:47 PM: [ERROR] Channel registration failed. Reason: Only one usage of each socket address (protocol/network address/port) is normally permitted
, Callstack:    at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
   at System.Net.Sockets.Socket.Bind(EndPoint localEP)
   at System.Net.Sockets.TcpListener.Start(Int32 backlog)
   at System.Runtime.Remoting.Channels.ExclusiveTcpListener.Start(Boolean exclusiveAddressUse)
   at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.StartListening(Object data)
   at System.Runtime.Remoting.Channels.Tcp.TcpChannel..ctor(Int32 port)
   at Agent.AgentApplication.Main(String[] args) in d:\BuildFarm\buildmachine_++depot+UE4-Releases+4.9\Engine\Source\Programs\UnrealSwarm\Agent\AgentApplication.cs:line 136.

I have tried making a completely new project and I get the same issue when I build (except the build status shows 0 seconds instead of 2). Just to add, normally it takes less than a minute to build the lighting of a brand new project.

My specs if needed:

  • Gtx 770 2gb

  • I7 4770k

  • 16gb ram

Also, but likely unrelated, I am unable to purchase anything from the marketplace anymore (says something went wrong). Maybe it’s related?


I think you need check firewall/antivirus config. When Swarm Agent start in first time, you see Windows Security Alert window (if you use MS Windows security system) or security alert message from third party firewall/antivirus. In this window you must allow Swarm Agent activity. In otherwise you get an error message. If you not got any security messages about Swarm Agent activity, perhaps security system automatically locks Swarm Agent. Check permission for Swarm Agent in Windows Firewall Configuration or in configuration of third party security software.

This worked I guess. Maybe I just had to restart my computer or something.

I’ve been using Unreal for a almost a year now and this is the first time swarm agent acted up, and I never had issues with security programs blocking it, so I found it strange for that to be the issue.

Nonetheless, I added exclusions to Swarm Agent on my security software’s.