Swap Default 3rd Person Skeletal Mesh for Paragon Asset?

I swapped the skeletal mesh in the properties of the ThirdPersonCharacter properties for Grux but I still spawn as the mannequin.
What gives?

Just tried with Gadget. Works if you use a default third person project. I switched the mesh in the ThirdPersonCharacter blueprint and the mannequin in the map switched to the Gadget mesh. I found lots of anims in the anim folder of Gadget but no anim BP. So for testing purpose I switched the Rig of the Gadget mesh to humanod rig (same as the mannequin) and retargetted the mannequin jump and run anims to Gadgets mesh. I choosed it in the ThirdPersonCharacter blueprint as well. However … this is really just for testing. The anims of Gadget are more advanced than the third person mannequin ones. So usually you have to create an Anim BP for Gadget with all the anims from the Paragon asset.


Oh I forgot about this question! I figured it out a couple of weeks ago.
It went something like you explained.
I went into “Content->ThirdPersonBP->Blueprints” and opened “ThirdPersonGameMode” and changed the “Default Pawn Class” to “Revenant Player Character”
Then I went into the “Content->ParagonRevenant->Characters->Heroes->Revenant” and opened RevenantPlayerCharacter" and on the components tab highlight “Mesh”
Over on the right now see Mesh->Skeletal Mesh changed the skeletal mesh to the Revenant skin I want to use.

This gets you basic animation with a LMB attack (though no projectile/particle effects, just in Revenant’s case a recoil of his pistol), run and jump
It would be nice to figure out how to incorporate basic water interaction as well but for now that is enough.

Thanks! I guess I don’t have email notifications enabled. Apologies for taking so long to answer your quick reply.