Svn weird behavior

Hello. I’m using ue 4.1 with svn. When I’m trying to connect to repo it takes 2 minutes to connect after success message appears and icon in the top right corner becomes green. But I can’t do anything - not commit, not update. For example, changing blueprint even not shows any change icons in content browser. Right click on this blueprint shows me only Mark for Add option. After clicking on it another options become available, but selecting History or Diff does nothing. Also, selecting Check Out causes this error

The following assets could not be
successfully checked out from source
control: /Game/Blueprints/BP_Test

Source control log says:

Error svn: E215004: Authentication
failed and interactive prompting is
disabled; see the --force-interactive

Error svn: E215004: Unable to
connect to a repository at URL

Error svn: E215004: No more credentials or we tried too many

Error Authentication failed

Also, after restarting editor icon in the top right corner always yellow.


First of all (sorry if its a silly question), did you enter your password correctly in the login dialog?

Would it be possible for you to post your full log here to try and diagnose the issue (in /Saved/Logs directory)?

I’m very sorry. The problem was with my svn - it didn’t store my auth data. After deleting AppData\Roaming\Subversion\auth folder and relogining everything works fine.

I’m having this same error but on my mac and on 4.2, with svn hotfix. Any help would be amazing.

You may have to delete you auth data & re-enter your credentials. I am informed that on Mac this is stored in:


I am sorry, but I can’t find this folder. How would I go about this process of deleting the auth data on my mac?

Its a hidden folder, so you cant see this folder in finder without some shell script changes. You can delete it via the shell.

I’m new to mac’s so I need some help doing so. I have my shell open but don’t know the commands needed to navigate or delete the contents of the auth folder you mentioned.

Also, is there a way that I can permanently reveal hidden folders on my mac?

This should help:

This also looks useful:

Thanks for the help Tom. Unfortunately I keep getting the same error. And when I reopen unreal after deleting the auth data within the auth folder, I still see the SVN dialog holding onto the svn repository url and user name. I have to be honest, this is super frustrating. Something major has happened to SVN every update. I’m not really sure what to do now.

Can you be so kind as to tell me which version of SVN you are now using? Perhaps I have to upgrade the version from the app I used to check out the repository in the first place.


FYI, when we say ‘svn auth data’, we are meaning the private security data that SVN uses. This is separate and distinct form the URL and other login details that the Editor uses, so the fact that your URL is still present in the login dialog is not important.

As you are on Mac, you may however be suffering from this issue that was reported recently:

We are looking into upgrading the version of SVN that we ship with the Editor to address this issue.

I see from your other post that you are having issues with the repo version, so this may not be your issue after all. Ill continue in your new post.

Here is also another great stuff to show hidden files.

I usually use for to show hidden files Commander One. It is multifunctional, simple and easy to use. You can read this article which to help you. How to Show Hidden Files on Mac - learn common solutions