Surface pro 2 touch settings

Hi, i’m not sue if this is in the correct place but here goes.

I’m trying to use UE4 to run a touch screen interface demonstration. I’ve set it all up and works fine on my development PC with single clicks.

When i run it on my Surface Pro 2, i have to double tap to get it to respond like a click, this isn’t the case in the rest of windows 8, is there a setting i’m missing somewhere? The rest of the interface of the editor etc work as expected.

Howdy StuButler,

Thank you for reporting this issue. I have attempted to run the Editor on one of our touchscreen laptops here and have seen no issue with the tapping. I am not able to run a test on a surface pro 2 currently. What version of UE4 are you currently using? Any additional information would be greatly appreciated.

Thanks and have a great day!

Hi Sean,

Thanks for the quick reply!

I guess I should have provided a bit more info, was in a bit of a rush.

I’m running on the latest build of unreal from the launcher.

The issue is with hitboxes responding to taps when using blueprint based HUD (as in not UMG). I have a few test I want to try so I can attempt to confirm the issue, I will try these in an hour or so. I can always put together and example project and zip up for you to try. I can’t show my current project at request of the client.



Hey Stu,

A sample project would be great if you could. This would provide the best repro possible.


Hi Sean,

Sorry for the delay, got caught up trying to find more information on what i think is happening.

I’ve uploaded a demo project here: which has the same issues.

I’ve added in some text in the top corner which shows the position of the cursor.

I’ve worked out that the issue I’m having is this:

  • On the first tap, the mouse moves to the location tapped.
  • On the second tap, if the position is the same it will do a click action at the location tapped.

It’s this that is causing me to need to double tap on the surface to activate a click. As I said in my original post, this is not the case with the rest of the interface, a tap on a button such as play, clicks the button. This behaviour is only present when running the game.

I’ve “fixed” the bug in my project by swapping to using mouse over hit box instead or click, whilst this is fine it still seems a bit counter intuitive. There is a BP node you can easily swap in HUD Blueprint to see the “fix”.



Hey Stu,

Sorry to get back to you so late. I believe that you are correct with the issue lying within the Blueprint. There is a node that is being used called ‘Event Receive Hit Box Click’. The event is a references to the mouse cursor and may be causing the double click error.

I have written up TTP# 349078 and placed this issue into our bug database so that it may be fixed in a future release.

For the time being, you may want to use the workaround until this issue becomes resolved.

Thanks and have a great day!