Download

Support for special characters in DataTable from CSV file

Special characters like ą,ę,ó,ż,ź, etc. are lost (replaced with “?”) when importing data from .csv file into a DataTable. Here is what it does right now.

Since storing data like long dialogues/descriptions (in many languages), spreadsheet-calculated values, etc. in .csv file is very useful (or maybe even “essential”? :wink: ), it would be nice if we could import it without problems. I see that it’s possible to type special characters directly in DataTable in editor and it works there, so I guess that’s a matter of some CSV importer tweaking.

Hi Slavq,

This is a known issue as UE-19896. According to NormanFoxLee here, if you use google sheets to export the .csv it does not receive the same errors. Try that and see if it helps you until we can find the root cause of this error.

I’ve tried exporting .csv with both Excel and Calc (LibreOffice) with no success - but Google Sheets indeed helped! I’ll use this as a workaround for now, thanks!

I’ve solved the problem by re-saving the csv text file with UTF-8 encoding. Used Sublime Text, but any advanced text editor will do.

Still an issue in UE4.26. Excel does have the option of UTF-8 export. Thanks for the suggestions! ^