Download

Support for spacemouse

Hello, we really need an official plugin for 3dconnexion spacemouse. we are relying on 3rd party developers right now, and even if they are doing a fantastic job, in term of productivity we can’t rely on those indefinitely. we can’t rely on sources who basically can stop their development any time
when you go to 3Dconnexion site, you’ll see all the programs of the milky way are supported there except UE. Epic please consider this. 3Dconnexion spacemouse is not an anecdotic product

3Dconnexion have just released a new driver 10.7.1 which includes a plugin for the Unreal Editor. I have installed the driver, but unfortunately when I try to new a new or existing 4.26 project I get this error -

Plugin ‘TDxUnrealEditor’ failed to load because module ‘TDxUnrealEditor’ could not be found. Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project.

The 3Dconnexion drive installer has placed the UE plugin in the correct plugin folder.

I have put in a support request with 3Dconnexion and posted the error on their forum.

Would be interested to here from other people who have tried to use this plugin.

thanks for the update. this is always good news. microdee has updated his (or her?) plugin. and it works great with 4.26.0. you can find it on github. it says 4.26.7, but it’s actually for 4.26.0

SpaceMouse-1.1.0-UE_4.26.7z
7z is actually the fileformat :smiley: so its SpaceMouse-1.1.0-UE_4.26 :wink:

Got the same problem with 3Dconnexion driver (10.7.1) - UE 4.26 is not working.
Uninstall of 3Dconnexion driver helped.

Even ZBrush now supports my 3D mouse, yet Epic cannot implement a working version, how embarrassing Epic…

My plugin is also available on Marketplace SpaceMouse for Unreal Engine in Code Plugins - UE Marketplace . It doesn’t need official drivers installed, if for any reason you don’t like 3DxWare or you don’t like their TDxUnrealEditor plugin.

Epic just started to financially support the development of my plugin so, I think they’re doing more than their part in this.

Cross post of 3D Connexion Forums. This fixed the issue. (Running 4.26.1)

Post by ngomes » Mon Jan 11, 2021 10:20 am

Hi,

Firstly, our apologies for not getting back to you on this issue any sooner.

When we shipped the plugin for Unreal Editor, version 4.26 was still in pre-release. This means the “BuildId” number of the plugin module does not match the application, triggering the “failed to load” error.

Since 4.26 has now been released, we should be able to rebuild the plugin with the compatible “BuildId” just like we have for engine version 4.25 and older.

In the meantime, I suggest the following:

  1. Close Unreal Editor v. 4.26.0.
  2. Ensure you’re running the release version of 4.26 (not a beta or other pre-release build; if necessary, check the application’s “Build.version” file in the “Build” directory).
  3. In File Explorer, go to “<Unreal Engine 4.26 installation>\Engine\Plugins\3Dconnexion\TDxUnrealEditor\Binaries\Win64”.
  4. Open the “UE4Editor.modules” file in a text editor (notepad.exe, say).
  5. Change the “BuildId” number to “14830424” and close the file.
  6. Start Unreal Editor and load your project.

Alternatively and if you do not wish to use the plugin, simply delete the “3Dconnexion” folder in the “<Unreal Engine 4.26 installation>\Engine\Plugins” directory.

@ERJ145 Thanks! I can confirm that the above instructions work, as of 03-08-2021.

@ERJ145 This Suggest dosn´t work for my Enterprise. I didn´t find …\Plugins\3Dconnexion… but …\Plugins\Enterprise… and change “5. Change the “BuildId” number to “14830424” and close the file.” was there. But it still doesn´t work.

Maybe it’s the difference in the hardware. I am running a SpaceMouse Pro.

My Space Pilot Pro works in UE4.26, after change in UE4Editor.modules file.
The same modification does not work in UE4.26 for Aximmetry DE, which I need. Any idea?