Support for Android Vivo Phone

Hello, I am trying to develop applications for the Vivo Xplay 3S with these specs:

OS Android 4.3 – 1440 x 2560 pixels – Qualcomm Snapdragon 800 MSM8974AB – Quad core, 2300 MHz, Krait 400 – Adreno 330

Tried packaging all the sample projects offered by the engine, but unfortunately non seem to be working (HDR off and on). They start initially (maybe play for half a second) then freeze. The current build of the engine also freezes, only sometimes the music continues in background. In all crashes the program eventually crashes. Graphics look amazing on the phone from the single startup frame…

According to compatibility list this phone should have full compatibility. Is there known issues with this phone (hardware or software) that is restricting the application from running correctly? Are there are upcoming improvements to the engine that may resolve any known issues? Anything suggested to remedy this issue with current build?

Check logcat output, it might give you a hint whats going on

Hi, I have tried testing various applications logCat but cannot pinpoint anything obviously suspicious. I have attached a logCat for the tappychicken sample. It didn’t seem to render anything, only just hang. Any one have an idea and can give pointers?

link text

This is a logCat from the reflections sample tha renders a frame or two before stopping and music continues playing. link text

After some investigation it seems like there might be an issue presented by a generic error message in the logCat…

D/OpenGLRenderer(1124): GL error from OpenGLRenderer: 0x502


Any ideas anyone?

Reflations demo? thats too heavy for mobile, try tappy chicken

As I stated above all demos are not working on this phone (I also included tappy chicken as reference) . I used the reflections demo because it works on all other adreno 330 devices that I have tried… except this one. It should be the heaviest demo I know of to push the limits and still run >40fps. All logCats give the same results regardless.

Hi pal,

Thank you for your report. There have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

Thanks very much!