"Support Compute Skincache" crashes games on Linux

Hi guys,

These are my specs:

Unreal 4.22
Arch Linux - Linux diogobaeder-desktop 5.0.7-arch1-1-ARCH #1 SMP PREEMPT Mon Apr 8 10:37:08 UTC 2019 x86_64 GNU/Linux
Nvidia GeForce GTX 1050 TI

What’s happening is that whenever I enable any feature that enables “Support Compute Skincache” as a dependency (like ray tracing for example), and repackage the game, the game crashes with a failure like this:

[2019.04.11-02.24.19:191][  0]LogCore: Error: appError called: Assertion failed:  [File:/home/diogobaeder/Downloads/jogos/UnrealEngine-4.22.0-release/Engine/Source/Runtime/Engine/Private/ShaderCompiler/ShaderCompiler.cpp] [Line: 3814] 
Missing global shader FRecomputeTangentsPerVertexPassCS's permutation 0, Please make sure cooking was successful.

Signal 11 caught.
Malloc Size=65538 LargeMemoryPoolOffset=65554

If I disable ray tracing and repackage, I still get the error. Only when I disable “Support Compute Skincache” itself and repackage I can get the game to run again.

Now, doing a diff between a working version of my project and the broken one, I noticed that I have this configuration on the broken version’s “DefaultEngine.ini” (and some other similar config files):


which I guess is related to that setting.

Is this a genuine bug? Or should I perhaps have compiled UE4 a bit differently? I just compiled it with “make”, no further arguments added.



We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.



Sure. Done. I didn’t get any reference for the opened Case, though. No idea how to keep track of that. Is there a way I can get updates for it?

Sorry, nevermind, just got the e-mail about Case # 00108060. Thanks!