Super Large Level Causes Object Jittering

I have a 255km by 255km large level in the upper atmosphere. The world origin is in the middle. Unfortunately the large level leads to issues when moving further away from the world origin. As you can see in the video objects start to jitter especially when moving. It fixes itself when moving closer to the world origin.

How can I fix the jittering?

What I tried:

  • I tried scaling the world down but the clouds and atmosphere get messed up when simply reducing their size.
  • I looked up similar issues and apparently there is something called World Origin Rebasing. But it is greyed out in my World Settings and I can’t figure out how to turn it on. Nor can I find how to do it otherwise.

Found a Solution. You need to rebase your world origin. I did it like this in my player blueprint.

All objects will stay where they were, but it will mess up Materials using the Absolute World position. To fix it you need to subtract the Actor Position or the Object Position from the World and it will not move on rebasing.

I believe UE5 uses more float space for world locations now.

1 Like