Download

Summary of Outage on answers.unrealengine.com - a Small Number of Users are Affected

We have an outage on answers.unrealengine.com yesterday that affected a small number of users. Users was unable to login to answers.unrealengine.com. Users that have ‘remember me’ checked are not impacted.

We apologize for the inconvenience this may have caused. There are efforts in motion to make sure that this doesn’t happen again.

Background information:
We have an authentication system that is used by all our websites, including unrealengine.com, forums.unrealengine.com, wiki.unrealengine.com, andanswers.unrealengine.com.
We engaged external vendor to help us build and maintain answers.unrealengine.com.

Summary:
Due to lack of communication on our side, our external vendor was not notified of the changes that we made to authentication service. Hence, no proper testing was done.
We identified the problem, and have since worked with our external vendor to make sure the proper communication channel is setup properly.
On the bright side, we just made our code more resilient :slight_smile:

Below are the details of what happened:
11 June early afternoon PST: we released a number of backend server code, which includes our authentication service code.
12 June early morning PST: we received report that some users failed to login.
Upon investigation,we found out the root cause at 6.31 AM PST, and pushed out the fix at 6.44 AM PST.

For those technical folks out there:
The issue is caused by us making changes to return more attributes on the login call.
Our code on answers.unrealengine.com did a strict de-marshalling, hence failed on new attributes.
We fixed this by making de-marshalling to be less strict to help with backward compatibility and avoid issues like this from happening.

Thanks Junaili. I have ‘‘Remember Me’’ turned on by default so i didn’t had any login issues. Thanks for fixing it up soon. :slight_smile:

Hello! Here on october 27, today, I’m having this trouble since 1 week ago. It appears that I’m logged on but when I try to post a question i just recieve this message: “There was an error contacting the remote service”, is this problem still until now?

*This on answerhub only
**I tryed IE, Chrome, FFox, Opera.

Hi RODSSS,

I’m sorry to hear you are having the issue with the Answerhub. No, I am not aware of such an issue affecting any other users at this time, so this may just be isolated to your account. We’ll do an investigation into your account to see if we can identify the issue, and I’ll follow up here.

Actually I may have identified the issue. You had two accounts with the same information (sometimes caused due to a server glitch during account creation) and this can cause problems such as you experienced. I modified one of the accounts to make it different. Can you please try logging out and logging back in now? Let me know if the issue is resolved.

I have two internet account: the first one which is primarily used at home cannot login to the forum (once it tried to reach accounts.unrealengine.com), and cannot use the launcher without going into offline mode, and totally cannot browse docs.unrealengine.com. I have to change to secondary internet account (but this is more expensive) so I can use all above without fuss.

Hi Syed (and anyone else with account issues),

Please send an email to accounts@unrealengine.com and explain the issue you are experiencing, along with the names of the accounts that are affected. Please also mention your location and your internet service provider, as that may have an effect.

Thanks