Suddenly Unable to Commit to git

I have been using a local git repository to manage my project successfully over a dozen commits. However, a few days ago I tried to make a commit and received an error, saying that my project was initialized. I checked and the .git is still there. The repo still shows up in github desktop. But for some reason Unreal won’t connect and initialization isn’t an option, because there already is a .git. Anyone have any idea?

Hi, I am the author of the Git plugin, can you check the logs in Saved/Logs/ and see what the exact error is?

Sorry, I see nothing interesting in the logs : could you start a new session of the Editor, try anything like Submit to Source Control, and capture all the logs up to this moment (that is, don’t close the editor do you will not add all the shutdown logs)

Edit: also it could be something related to an update of Github Desktop that is no more recognized by Unreal Engine

Thanks for the reply. I put together the output that included source control from the log of day it stopped working and the most recent attempt to commit. If you need more let me know, the logs are big.

Full log from a fresh session:

Okay, still no luck, no more information…

So on my mind there are two options :

  1. Either you install Git for Windows with the hope that the UE4.14 plugin catch it
  2. Or you try to upgrade the plugin, by installing my standalone plugin V2.5 in your project’s Plugins folder, which should at least give you some more information in logs

Grabbed the current version of the plugin, put it in my project folder and tried to launch. Unreal said it couldn’t build, so I went to VS to rebuild, got this:

Using the executable from git for windows did the trick. I am still able to use github desktop to manage pushes to github, so the only issue was re-aiming the plugin to a different binary.

Thanks for your help.