Download

Substance painter problem exporting to UE4

I exported my textures using the UE4 package in substance painter and I deactivated RGB’s when importing my roughness/metallic map in UE4 but I still can’t get the part of my object that are metallic to look metallic.

I followed the instruction found here: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums

but I still can’t get it to work. Any help?

Here are the maps that I got from Substance painter:



Here’s what it looks like in the substance painter renderer:

Here’s what it look like in UE4:



Thanks for the help

Try to export textures in TGA format

still doesnt work :frowning:

try to put 8 bits

Hello!

Could you show us in ‘white/black’ your metallic texture please?

Hello,
Multiply the red output with a small number before put in Metallic node…

Your roughness channel is empty

Looking at the URL of your linked images I guess you have not switched to the correct Metallic/Roughness shader when setting up your project in substance painter.

Hey you should put a specular output in Painter in your roughness/metallic map. My output settings in Painter are:
Channel R: metallic
Channel G: roughness
Channel B: specular

Than take the map in UE and deactivate RGBs…after this step you should have a green overlayed map.

All information of the individual channels should be black and white.

I hope it works…just try it:)

Best Regards

Vjaceslav T.

try dragging in to the scene a reflection capture sphere, and you will have the metal look that is missing