Download

Substance Material

Gostaria de tirar uma dúvida, se a UE4 não está mais arquivos SBSAR (Substance Designer), como a UDK trabalhava pensei que iriam continuar, pois é um arquivo muito mais leve e de qualidade. No caso se ainda funciona, podem me informar como funciona ?, pois tentei abrir e não consegui.

Se alguém puder tirar essa dúvida eu agradeço

Não,não funciona.A Allegorithmic ainda não esta dando suporte para a UE4.

Para quem usa Substance Designer,otima noticia!
Substance designer 4.2 com suporte para UE4.

Eles lançaram ontem um plugin pro UE4, ainda está em fase beta e acho que só funciona pro windows. (o que é ruim pra mim já que uso um mac).

Eu não cheguei a ver em detalhes como faz pra instalar, mas acredito que tenha que pegar o código no gitHub, compilar e instalar. Quem tiver mais detalhes posta ai.

Olá Rafael…

Sim você pode baixar a versao 0.3 do Unreal direto do Fork da Allegorithmics e compilar que vai funcionar.
Eu cheguei a compilar o codigo de integracao do plugin para a versao 4.1 do UE4, mas existe um bloqueio na DLL para que impede executar o plugin em versões ainda não oficiais.

584bca94110ce5dfd4521b33e4084a65be3e305d.jpeg

3534d83884603c03de395d2cdfaf7a1abfe30857.jpeg

Mas compila pro MAC? Eu dei uma olhada na pasta do Git e parecia dar suporte apenas pra Windows. Estou relutando aqui pra instalar o Bootcamp e perder boa parte do meu HD só pra instalar o Windows.

Bom o Unreal Engine 4 tem versao pra Mac, porem nao tentei compilar para Mac !
Acredito queo Substance Design deva funcionar para Mac caso consiga trabalhar com os plugins em formado dll !

O UE4 tem uma pasta MONO em ThirdParty que usa isto para compilar ou converter cada assembly para Mac … POrem como o Substance não nos entrega o source code deles, teremos que ficar na dependencia deles compilarem este suporte !

Plugin do Substance não funciona em UE4 4.3

Olá Willismar, como faço pra instalar o plugin do substance no UE4 4.3? Disseram que era apenas copiar a pasta do plugin pra dentro do diretorio do projeto mas isso nao funciona, aparece o erro de mensagem da sua segunda imagem: 3534d83884603c03de395d2cdfaf7a1abfe30857.jpeg

O plugin só funciona na versão 4.3+ da engine.

A propósito, não precisa mais baixar do GitHub e recompilar a engine. É só baixar o plugin que tem no site da Allegorithmic agora, extrair para a pasta de plugins da UE4.3, e deu.