Sub levels constantly loading when using level streaming

So when I use level streaming all my sublevels constanly load, if I manually unload them (using BP) they reload automatically. Does anyone know what is happening?

Hi Arthur,

If you right-click on the sub level in the Levels window, check Change Streaming Method and make sure it’s set to Blueprint rather than Always Loaded. If they’re all set to Blueprint, let us see some screenshots of your load/unload setup, or upload your project or a small test project that has the same issue, and get us a download link. Thanks!

Hi Arthur,

We haven’t heard back from you yet, so I’m resolving this post for now. If you are still experiencing an issue with sub-levels, please feel free to reply with the information requested above and we can continue assisting. Thanks!

ohh thank you, in version 4.8.2 there isnt any “change streaming method”(not at least I could find), however I solved the problem!! I created a layer with “distance streaming disable” and assigned all my sub levels to it. now I can (un)load the by BPs, if you like I could post some prints? thanks for the help

The Change Streaming Method can be found by right-clicking on the sub level in the Levels window. Should look like this:

51557-changestreamingmethod.png

Glad you found another method! Feel free to post images to help other users that may run into the same issue. Thanks!

Apparently there isn’t this option for me

<

For anyone out there,t hat’s how I’ve done: First you should open the level windows by: Windows > Levels
In the Levels window press the button “Summons world composition” on the right of magnifying glass
Finally in the World Composition press the + button to add a new layer and disable the streaming distance like in the picture, and its done.

52838-printgringo2.png

Thank you for the solution. Been stuck for a day trying to solve this problem. Turn out it was also documented in Unreal wiki.

Layers hold information about streaming distances, so levels assigned to a particular layer will inherit that streaming distance. Levels assigned to a layer with streaming distance disabled will be excluded from distance streaming, and can instead be controlled using Blueprints.

1: u need to turn off ‘Enable World Composition’ in world settings

2: drag ur sub-level to the Levels Manually

then u will find the ‘Change Streaming Method’

^^ THIS

Thanks so much mate - exactly the answer I needed.

What a champion.