Stuck on Verifying process

Hi ! So, when I heard that UE4 was free I ran here to download it… Downloaded the Epic Games Launcher… downloaded UE 4.7.1…and when it seemed that was gonna end…it stopped on the Verifying process… so I think something went wrong… because it won’t move.

How can I fix this ?

check, I have the same issue.


Please try the suggestions in the ‘Launcher is unable to download content’ section in the link below. If nothing fixes the issue, make sure to follow the steps towards the bottom and get your ‘Debugging logs’. They will help us investigate the issue.

Hi, just encountered the same issue. Noticed that I was somehow logged out of the Epic Games Launcher. Logged back in and verification continued and install completed.

If you’re logged in and encountering the issue, try logging out and back in. I’m currently on an unstable internet connection which I suspect is the reason I happened to log off; you should confirm that yours is okay.

Do you guys see anything in your Vault Cache folder? It’s located here: C:\Program Files\Epic Games\Launcher\VaultCache

If you have anything there, try deleting it and restarting your download.

-Max B.

Hi Max, wouldn’t that mean starting the entire 4gb download again?
When I logged back into the system enabled it to pick up from the 90% it had been stuck at and complete successfully. Hopefully it’s also a session issue for the rest of the guys but at least now I know a good fix, thanks

yes this would restarting the download again. If you haven’t tried to cancel and resume the engine already this would the next step.

-Max B.

I did log out and log back in, but it didn’t work.

It worked for me. I left it on verifying process and went away for 15 minutes and when I came back, TaDa, The engine had been installed successfully. I had no programs running in the background so the main priority for the CPU was the verifiying process, even my antivirus was off.

Were you guys downloading a new engine version or updating an engine you already had downloaded?

Chief’s fix worked for me. I had this same problem “stuck at 90%”. I went to my UserName on the menu and it said “Sign In”. I signed in, and after a minute or so, it began to proceed again. BTW, Max, I was downloading a fresh install.

Ok, had same issue on windows 10, after a million of BSOD I’ve managed to launch it by going to the folder of the engine
Epic Games\4.13\Engine\Binaries\Win64 and launching it with win 8 compatibility and as an administrator.

I’m new to UE4, and I installed the Epic Games launcher last night. However I could not run it properly for some strange reason. What’s happening is when I open it, it will begin verifying an update, then the verification disappears, rather quickly, then reappears after a seemingly random amount of time. I’m looking for a fix for this. I am trying to run the launcher (V7.0.0.) on a Mac updated to “Mac High Sierra”. Applications running in the background are; Safari, ITunes, HID Explorer, and Finder. I have ate,pled to restart my computer and run it, but when I restart it, several applications that weren’t originally open, will open, such as Steam. Additionally when I restart, the launcher acts “normally”, it launches, verifies and update for maybe 10 seconds, then after at least a 30 sec wait, it resumes the infinite verification loop. I also tried to see if I could find the “VaultChache” folder to no avail. If you know what could help please let me know.

I’ve been running into the same issue. I logged off and logged back in, that didnt work. I also restarted and shut down my computer and that hasn’t worked either. I made it so that UE4 was the only application on. It’s still verifying and it’s been over 15 minutes. All of this time combined has been about 3+ hours and it’s still not opening. I don’t understand what’s going on and why it’s doing this

I was trying to get my name changed, but then it said that I had to verify something. How do I do that?