Download

Stuck on vehicle creation

So I have been following the vehicle creation tutorials from epic (youtube videos) and have found that when I get to putting the asset in to my level things go a bit weird.

I’ve set up the car so that the main body mesh is the root, the wheels are then attached to that in a hierarchy before being exported as an fbx. (I have set up a version using bones and it goes crazy too)

When I bring it in to Unreal (a rigid mesh as shown in the videos) it sees the 4 wheels connected (set as kinematic) and has the physics asset set up but when I click on simulate it goes crazy and starts bouncing all over the place.

I’m not sure what is going on with it.

The scale is in Centimetres, Z is Up and the car is facing down the positive X axis.

Any suggestions as to what is going wrong would be greatly appreciated.
Cheers
Mat-Art

First thing to check is whether your root mesh has its pivot at 0,0,0 in world space before you export it.

Hi Xenome,
It was originally exported at 0,0,0. Reset Xform and collapsed modifier stack.
I think it is definitely something to do with the wheels. I did a test with just the main frame of the car and it dropped to the surface no issues.
Add the wheels back in and it looks like it is having a fit.
Weird
Mat-Art

OK, next possibility: select all the physics bodies in PhAT (should be the main + four wheel bodies) and switch off collision. Just in case they are fighting each other so to speak.

Are the bodies freaking out inside PhAT or in the actual game? When the car asset is put into the game the wheel collision is automatically turned off and all constraints between the wheels and the rest of the bodies are turned off. We mainly use the wheel rigid bodies for determining the light bounding volume.

This is not the case inside PhAT. PhAT has no knowledge that this is going to be a car. I still wouldn’t expect the wheels to go flying, but I’m just saying that it might work ok in the game. There are some cases where having a non root kinematic inside phat can cause some issues. We’re working on a better solution for this.

Hi Xenome, When you say PhAT, you are meaning the Physics asset window?
Hi Ori, when I’ve got the car in the Physics asset window it is freaking out, when I’ve set it as the default pawn and start the game it is also freaking out and spinning all over. It isn’t just the wheels that are tumbling round the body does too.
Bit frustrating as to why it is happening.
Cheers
Mat-Art

Yes, that’s the one.

And, just to make sure an obvious thing - did you assign the correct bone names representing the wheels in the vehicle blueprint? And assigned a Wheel Class to each of them? (Defaults/Vehicle Setup/Wheel Setups)

Hi Xenome,
I’ve re done the tutorial, this time I’ve used bones rather than the hierarchy system and all the meshes have been combined to one object and a skin applied. I’ve setup the WheeledVehicle component and put the skeletal mesh in it. The wheels are set up and the Physics asset is being less hectic than before, the main body drops to the floor and the wheels flop around. However when the wheels are made kinematic the whole object flies away, changing the collision does nothing. I’ve set the default pawn to my buggy and when it plays the car drops to the floor and the wheels float and flap around the frame of the car in a rather comical but quite frustrating manner.
Any Ideas
Cheers
Mat-Art

Well, having all of it skinned as a single mesh really shouldn’t be necessary.

The only thing I can suggest at this point is that you take a really close look at the BP vehicle template, and carefully compare the setup of that blue sedan to your own vehicle until you find some discrepancy.

Hi Xenome,
Sounds like a plan, cheers for the advice. Think I will try it again tomorrow with a fresh head.
Mat-Art

So I’ve been going through the process of getting a vehicle in to unreal and it has reached a point where I am totally stuck. Not sure how to get the thing working.
I’ve made a video and put it here showing what I am doing and what is happening.

Am I missing something obvious or is it a case that I’ve set something up wrong?
Any help greatly appreciated
Cheers
Mat-Art

it looks like there might be something wrong with your physics asset (as it shouldn’t spin like that). have you tried using a simple box for your car body’s collision by resetting the body’s sphere instead of deleting it? (like ori shows in his video), you can always make the box better after you’ve got the car working.

Hi Smokey, yeah I’ve been through all the shapes, unfortunately they all act the same.

I’ve even had a go at exporting the buggy from the vehicle level (from marketplace), back in to max to put it’s skeleton in my car. It doesn’t work floats around off the floor.

I’ve tried using a CAT rig, no joy. The car goes flying all over the place.

Really not sure what to do with it.
Cheers
Matt

Wild stab in the dark here, but is it possible that your root node is ever so slightly rotated away from pointing exactly forward?

No skinning is necessary for a basic chasis & wheels setup really. Follow these steps and see how it goes:

Get rid of all the bones
Set the body’s pivot to 0,0,0
Set each wheel’s pivot at wherever you set those bones in the video
Select the wheels and Link them to the body
Select everything and export

Import into the engine - Enable Import Rigid Mesh and Import Meshes in Bone Hierarchy
Open up Phat(create one if you dont have it already)
Delete all the physics bodies and create a box for the chasis of the car as smokey suggested(make sure it doesnt touch the floor - you can adjust its position and scale inside Phat editor), and capsules or spheres for the wheels.

Ignore all simulation absurdities in Phat and create your wheel and vehicle blueprints following Ori’s videos.

It has to work. If it doesnt, then you can create a simple car reproduce the issue and upload so that we can take a look.

ok I tried to reproduce your spinning car in my physics asset but couldn’t so it’s probably not that, the only thing I can say is what they^^ said.

Yeah, I’ve had models fly straight up in the air in PhAT, but still working just fine when fully set up in the vehicle movement component. Remember that you must at the very least assign your wheel names there in order for things to work just a little bit.

So try Jacky’s suggestion. It really should be completely straight forward.

Hi Guys,
Thanks for the replies, so basically, I’ve made a little test piece using cubes and cylinders which is behaving itself in the PhAT window. The difference was that in creating the bones I tried to give them a bit of length so that it is easier to spot the direction they are facing. I’ve made sure that they are spot on with their positioning and orientation.
I’ve rebuilt the bones for the buggy in the same method now and it seems to be behaving in the PhAT window, it is stationary in the game window (though floating above the ground). So that part seems to be a case of ensuring the bones are perfect alignment.
The new problem is that after hooking up the controls there is no movement, after spending most the day on it I think I’ll wait till tomorrow to start on this next part.
Getting there slowly though!
Thanks again for the help, I think if there wasn’t the help and suggestions from the forum I’d have quit by now!
Cheers
Mat-Art

not sure if i’m to late with this, but if your using a skeletal rig then make sure the root bone is at 0,0,0

i had a problem that the mesh flew off in phat and adding the root bone fixed it

Hi,
I had something like that happen when I tried to import a model from Blender BEFORE I applied GEODAV’s .FBX fix to the io routine. Basically, blender had added an extra bone to the top of the bone structure and messed things up bigtime during the FBX exporting process. You wouldn’t happen to be having a similar problem would you?