Stuck on compiling shaders on first load

Trying out UE5 for the first time on my M1 Max and it’s been stuck on compiling shaders for awhile now. Is this something that only happens on first load or is there something I need to do to fix it?

1 Like

same problem. It took 50 minutes to reach only 45 percent.

1 Like

Same here. I 'm creating the default vr project, it stays at 45 percent compiling headers for at least 40 minutes. When it finally ends and the project starts, it begins to compile about 7000 headers a second time, taking forever again.

My specs: i7 11th Gen, Nvidia 3060, 16 gb ram, win 10 home.

1 Like

RAM - need LOTS - and Drive space… I have 32GB of 4133 and I wasnt able to get anywhere without enabling 64 GIGs of VRAM for a total of 96GB. Also, the Characters have 30,000 shaders alone, so try opening a empty level and just the player and let thoes compile … before launching the small level map…

Same here on a first install. Also stuck at 34%… strange. I’m loading it up on my newer Alienware laptop so it’s gotta work on one of these machines lol

2019 MBP 8 core i9 2.3ghz | 32gb RAM | Radeon Pro Vega 20 1.5gb VRAM + Intel UHD Graphics 630

Anyone get a solution to this? Im also stuck on 34%

2021 MBP M1 Max| 32gb ram

Can Confirm… 1st Load. 34% and holding.
Started around 10:40am.

Heyy, 45%
at 10:53am.

*Loaded at 11:00am
Must take a bit. Hopefully not every time.

iMac (Retina 5K, 27-inch, Late 2015
4 GHz Quad-Core Intel Core i7
32 GB 1600 MHz DDR3
MD Radeon R9 M395 2 GB


Started Archvis Template Project… 11:05ish
Back to Compiling Shaders @anonymous_user_33d86db7% (4000+ to go)

(2500+ @ 11:11am)
(600+ @ 11:18am)

45% @ 11:20 (1400+)
(900+ @ 11:22)
(200+ @ 11:25)

Initializing 71% @ 11:27

*Loaded @ 11:28am

Slowly loading things and blinking this message:

Stopped blinking message around 11:40am. But things are excessively jerky, for all things compute at the moment. Even my cursor is delayed.

Activity Monitor: Shaders taking up CPUs but overall around 75%. Must be intense on the GPU.

1 Like

what I did to solve it was manually change raytracing to false. you can do this by going to the project files location > config file and opened DefaultEngine.ini with notepad and changed r.RayTracing to false. you can find it quickly with ctrl + f in notepad.

1 Like

the problem is that as soon you need it, and you enable it, the same will happen.
The first time you lunch a project this will always happens…take time and depends on how fast your hard drive is, how much memory you have and how much free space you got.

One problem I had was with mds_stores which is Spotlight and it was trying to index UE5 files as it was compiling the shaders, used a LOT of CPU! There’s a solution to this on Stack Overflow: macbook pro - mds and mds_stores constantly consuming cpu - Ask Different

I added the UE5 folder to the Spotlight Privacy settings to avoid indexing which allowed more CPU to be used by UE5 and then it got through the process fine.

Thanks for the tip!

I added UE5 folder to Spotlight Privacy settings and saw a drop in CPU for the ShaderCompileWorker processes.

Here are the file paths:

/Users/Shared/Epic Games/UE_5.4

same here, stuck at 45%, it seems a Raytracing issue

Hey guys, I think this solves it, at least for 5.0.0. On opening old (just few months older actually) projects, I had the load up screen virtually stuck for hours at compiling shaders. Then I created a new project and compared all file contents between the two. Turns out the older project has these two lines in its Unreal Projects\MyProject\Config\DefaultEngine.ini:


These lines are not automatically defined anymore for newer projects. Remove them (or just put them both to ‘False’). It should not get blocked again at compiling shaders now.

PS: So yes, the issue seems to be solved not at performance level (increasing the number of workers/threads) but requiring a complete shutdown of shader compilation and/or ray-tracing on startup.

Sorry that I don’t have a solution to add - but I wanted to share that I am also on an M1 Max and installing UE5 on it for the first time and also got stuck on 34%.

4.40pm Started opening UE5 for first time
4.50pm Stuck on 34%
5.30pm Finally 45%
5.55pm (Over one hour later) - Suddenly finished

In conclusion: M1 Max users: it just takes a very long time to compile. The number in brackets will eventually go down. It will compile.

I just got 5.1. Same behavior. I’m using an M1 iMac, raytracing is not mentioned in the DefaultEngine.ini. Took a bunch of time to even start the editor, and a similar amount of time to open a new project based on the FPS template.

I understand that compiling shaders is a thing which needs to happen, but I don’t understand why it needs to happen every time I start a new project, especially since I haven’t even selected any at all.

1 Like

If this happens every time you start a new project, there is a problem. Perhaps it is an issue with permission and the hard drive or the cache. I suggest having a closer look at that.

Hi everyone,

Today I launched UE5.1.1 and it loaded a random project within a couple of seconds, no shader problems, nothing. Then I decided to test out the car configurator project from the marketplace (purelly out of fun), the marketplace said that it wasn’t compatible with 5.1 (but it mentioned that it was, but whatever). I loaded it up on 5.0.3 and it worked normaly. After powering of and coming back later all of my other projects were still fine and loaded with no compiling shader wait time, but I accidentaly launched the car configurator project with 5.1.1 and the message said something about copying 5.0 to 5.1 (honestly I don’t remember the details). The project took about 20minutes instead of a couple of seconds and suddendly all of my other projects were compiling shaders for an hour (+8000) shaders even though there was nothing there and was a very small project.

My fix was deleting the car configurator project from my pc and it fixed everything. I honestly do not know why it worked, but it did. So I hope that this heleps someone who has a similar issue…

NOTE: This is a repost from another post: How is this acceptable? (compiling 8000+ shaders on a brand new installation) - #67 by RudaFelker