Download

Stuck for 3 months. . . and no direction on packaging

I am trying to package a game, and I had it working probably WAY back, but now whenever I try to package it fails.

First I apologize for the noobiness here. I don’t know what steps to take. I am totally lost have have been trying things for 3 months with no success. Can anyone help me? I am at the point of looking on Fivverr even to hire someone to remote in and try to fix it. Here are the Error and Warnings from the failed logs
UnrealPackagingLog.txt (70.5 KB)

any help?

Hi,
Some details, like packaging log with errors, will be really helpful :slight_smile:

I am sorry, still new to this. I am attaching a copy of all the warnings and Errors from the failed packaging log. If you need more I can get whatever I need to help. UnrealPackagingLog.txt (70.5 KB)

No problem :slight_smile:
This log doesn’t contains actual error. But you could try following steps:

  1. Close UE4.
  2. Delete folders in project: Intermediate and Saved
  3. Start UE4 and try packaging your game again

Let me know if it helps. Otherwise - attach full log file with all building/packaging process.

If I delete the folders wouldn’t it break the projects? since if it had a item that was referenced in the game build it wouldn’t be able to find it?

I have restarted a million times lol. I have been stuck on this for MONTHS. I never thought about posting questions here.

I will get the full log file, should I just copy and past it in notepad like I did, or is there a better way?

Intermediate and Saved folders inside projects folder are safe to delete. Here on screenshot:
FolderStructure.png

I deleted the Intermediate and saved folder, restarted and tried again. still failed, but did it in about 10 min, instead of 20 to 30. Also had A LOT more red. Here is the full log file . . . unrealprojecissue2.txt (712 KB)

Hi,
Can you share android SDK settings? For project and UE4 global?
And, have you made any changes in Android SDK in last months?

Are any of you guys familiar with Android App Bundles and GooglePAD (Google Play Asset Delivery)? Because it seems like i’m the only one who knows of it’s existence lol
You can upload a single .aab file to Google Play containing ARMV4 and ARMV7 as well as all available textures and it will dynamically install the right one depending on the device.

Have you guys tried using it? If so, did you get it to work? i can’t for the life of me get it to work… Everytime i upload it to the google play store, i get a Failed to open descriptor file issue