Download

Struct variable missing after migrate

After migrating my project from 4.25 to 4.27 there is an error across a load of my BP’s that one of my structs is missing. The struct is also greyed out in each of my blueprints. Have tried re-migrating everything but I still have the same problem.

Each BP has the error - struct recreated but variable is missing.

This struct is used across a ton of my blueprints so trying to avoid having to go through every BP and recreate a new variable and reconnect all the pins (it is a large struct and they are split so cannot just replace them)

Any ideas of a fix here?

have tried re-saving the struct (which does appear in my content folder and opens up no problem) but none of my BPs seem to be able to find or reference the struct.

Just to clarify, you “migrated” vs “Cloning and Updating”?

If you “Migrated”, then migrate the Struct first, then the code (actors etc).

Another option is to Duplicate the used struct. Delete the referenced (Force Delete), use the replace with option and select the duplicated struct.