stretching textures in UE

Hello everyone!) What could be the problem? Does stretching appear on UV in Unreal? In Maya and Painter, the texture is displayed without stretching.
https://drive.google.com/drive/folders/1LNiAUjGvpFWnjHvyoh7v-K3WG9FzPBGT?usp=share_link

1 Like

Could you provide an image?

If there is texture stretching it is likely due to a stretched UV map or a stretched texture. It could also be connected to Texture MipMaps.

1 Like

hi @Antonf1

Are you importing the UV maps? or is Unreal using some default?
Have you tried remapping the UVs with Unreals auto unwrap feature?

also as @EliasWick stated check the texture is not stretched inside Unreal

Whenever you export a mesh, it will import the UV map from the model. You can check the UV map inside of Unreal Engine if you open the mesh viewport. This is done by simply double-clicking on the mesh.

The auto unwrap feature is not always going to give you the best unwrapping result.

I agree not always the best, but if that worked then maybe the original UV wasn’t exported from his 3D package or some settings were not correct on the export. Just something that can help towards diagnosing the issue.

As I do not use Painter or Maya I cannot really comment on the export routines and settings I’m afraid.

Good tip on checking the UV thought in the mesh viewer

Luck would have it, a recent post:

Not sure how relevant

Thanks for the answers. The model and UV were made in Maya. There the texture is displayed without stretching. Also in Painter without stretching. I tried to import it into Blender, it also has a texture without stretching. But in Unreal, the texture is distorted. If you go to the UV Editor, everything looks good.

Is it a problem in the Material? Is there something strange looking in there?
Have you tried making a new material that just references the texture and nothing else and putting that onto your mesh?

It looks like an incorrect display of the UV model in the main window of the UE. Created new material, all the same.

I noticed such a feature. If the UV shells are small, then the texture in Unreal is distorted.

1 Like

How did you actually fix it? I see the difference in the 2 images, the UV was stretched now we see it compared to how it should be. Would be good to enlight others what steps you took to fix it.

Hi, there is still a problem in that screenshot. If the UV shells are small, then the texture in Unreal is distorted. But today I found a solution to the problem! You need to check the Use Full Precision UVs checkbox in the Static Mesh options. Then the distortion in the texture will disappear.

3 Likes

Sometimes the simplest option is the right or best 1! good work

1 Like