Streaming Texture BUGs

I have all sorts of issues… from the editor streaming in textures at full res with forced method even though those textures are imported with out the forced… streaming is on… … then at the same time sometimes textures will switch them self to forced to not forced as i float around the level…

Texture memory is being eaten up… streaming not functioning correctly… Things a mile away or behind walls are getting streamed in at high resolutions.

See the link to the forum posts and let me know how i can be of assitance to helping figure this out. There are plenty of screenshots there of all the debug commands and tests we have tried. The project is like 50gb… so let me know if there is a developer i should send it to as i dont want to send out a link for the public to download my project.

Hi, did you read and try the texture streaming debugging methods described in the docs?

Also, did you try the ProfileGPU command and other performance profiling methods described here:

yes been through all of it… see the forum post. There is a lot of back and forth. The forum post started with performance questions but turned into texture streaming issues and questions and problem solving. With the conclusion it being a bug.

Hey kurylo3d,

I read through your forum post and have been assigned this issue as well as another user experiencing the same issue. As Ryan B. was saying, getting a repro for this could prove to be difficult as this issue seems to be dependent on a heavy amount of content and certain profiling and performance optimizations. The same project you are experiencing issues with might not produce the same results on my machine if you were to send it to me (not to mention the shear size of the project itself).

To that note, I have gone ahead and entered a bug report for this issue (UE-21800), and we appreciate you taking the time to investigate and report the issue. When an engineer/developer has addressed and found a solution to the bug, someone will update this post as to its’ status. If this bug is marked as fixed, we will add it to the Release Notes (found in our Documentation or Forums) for the upcoming release it has been marked to be integrated.

Update For reference the bug entered is UE-21800. It has been verified and fixed as number of fixes were entered into recent versions that address the issues mentioned here.

If you have any other questions or need additional assistance, please let me know and I will be glad to help.

Thank you,

Thanks Andrew. Let me know if you need my project to reproduce it. I have reproduced it on the same project with 2 different computers… Comp 1 : core i7 4.4ghz with 980 gtx… and Comp2: core i7 3.5 ghz with gtx 590

Both comps have an occulus rift and have used VR

Was the Occulus plugged into the computer at anytime when you were testing this issue? If this is the case, do me a favor and unplug and disable the Occulus. Run your tests again under this condition and let me know what you discover, please.

Its always plugged in but not always used to run it. I will test out unplugging it , restarting the computer and then launchign the editor sometime tomorrow.

Ok Tested(unplugged, restarted, and exited occulus runtim. The textures are still in there full res from liststreamingtextures and investigatetexture. I am however testing it in editor mode so i have access to the outputwindow. Is there a way to test it with standalone run mode? … i mean i can use the commands in the console, but i have no output window to view their results with a standalone run.

There is not much more you can do about the bug until it is addressed. As Ryan B. suggested, you would want to over optimize to account for the full resolution textures. You could honestly try just increasing your ‘r.Streaming.PoolSize 2000 MB’ which actually is not a super high value.

Until then, I would do your best to work around the issue culling things you don’t need, and reducing certain draw calls based on what you need to have rendered to the screen.

Curious. Should the pool size reflect how much memory u have in the gpu? Or is that something entirely. Is there a specific pool i should target if i wanted this thing running on a gtx 580 or gtx 560?

No, the pool memory is not completely reliant on your GPU’s amount of memory, but with medium-end cards you don’t usually want to go past 3000 or 4000 MB.

good to know… i thought i was supposed to stay below 700mb or 512mb for the pool for whatever reason. Thanks.

Question, are my constant lag spikes when floating or rotating in places due to this issue as well? I get a lot of lag spikes that are very irritating. They happen like every 15 feet. Or in someplaces just from rotating the camera. Is there a solution for me with that?

Also i switched the pool to 3000 with the gtx 590 (probably functioning as a 580 because no dual gpu support)… Now that i switched that to 3000 everything is sharp, BUT i get constant lag spikes in areas… even if my camera is stationary. Like it drops 5 or 10 fps… in like 3 second bursts… that dont end. For example normally at 33 fps it drops to like 27 fps… (or its just reporting as 27 cause its freezes)… so every 3 second it gives me the lag spike… for an instant… and back to 33 inbetween that… its horrible… what would be causing that?

*Update, not so sure those lag spikes have anything to do with the r.streaming.poolsize… seems like that happens even when its at 300. Not sure what would be causing that…standing still and lag spikes. no game logic … its just art…

When running tests performance tests, there are options you can check to help with consistency. In your project settings there is an option within the ‘General Settings’ section to disable the ‘Smooth Framerate’ option. Try this in conjunction with reducing the engine scalability settings a bit. Keep in mind, if your textures are not at Epic setting you might see a loss in quality.

I already switched everything to low except for view distance, shadows and textures.

And I have actually already disabled smooth framerate for whatever reason… probably testing VR and have read that somewhere.

Neitehr of these help.

Its as though somethign temporary is happening everytime i slightly move the camera… for example im sitting in this spot at 33 fps… take my hand off the mouse and let it stay lookign straight ahead… and it literally jumps to 48 fps… and stays there… until i move the camera again. (this is without hte lag spikes… if i move around enough i start getting freezing lag spikes :/)

I dont know what else to do other then to try again for performance after i build again to rule that out… though i didnt do anything other then place decals around in teh scene… so not sure how that would have an effect.

Well to that end, there is not much more assistance I can offer aside from suggesting you continue on your path to optimizing your project for the time being, until the bug fix has been implemented and the engine version associated is released.

Decals do impact rendering, and if they are very high detailed with a lot of instructions, their shader complexity could affect your project performance. Use the Shader Complexity (Alt+8) to enter this view mode. White indicates high shader complexity, red if medium to fair complexity, and green is lightly complex.

Thats definently not the issue. I have like 5-10 decals in the entire scene and they arent even in view. The frame rate spiking is in every area of the map and the decals have only been placed in 1 room so far.